Tempo Worklogs not Returned in Jira API

Hi, 

We have an integration using the standard Jira REST API. We pull all issues from our account, and for each issue we pull its worklogs. It has been working fine for the past 2 years. Additionally we have tempo installed since the begining.

So far all worklogs created via tempo were returned in the API calls, but starting this month we start noticing worklogs are not being returned. Only old ones.

Can anybody confirm if something in Tempo changed causing worklogs not to be returned via de standard Jira API anymore? Also it seems the Tempo API is not working at the moment, so this is a huge issue for us.

Thanks

2 answers

My client has the same problem! Since the date they updated the Tempo plugin their worklogs are not visible using JIRA API. I see that I can get the data using Tempo API, but it's not proper way. Basically they messed up with the upgrade and ignored backwards compatibility.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

64 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you