403 Error when using IIS7


I am trying to set up confluence instance as an application within a Joomla site.


with the root being Joomla

I have set up tomcat to work with IIS 7 and am using ajp_iis isapi redirects from instructions from this site

Authentication is anonymous

server xml file is

server port="8000" shutdown="SHUTDOWN" debug="0">

<Service name="Tomcat-Standalone">

<Connector className="org.apache.coyote.tomcat4.CoyoteConnector" port="8090" minProcessors="5"


enableLookups="false" redirectPort="8443" acceptCount="10" debug="0" connectionTimeout="20000"

useURIValidationHack="false" URIEncoding="UTF-8"/>

<Connector port="8009" address="" enableLookups="false" redirectPort="8443" protocol="c:\ajp_iis\1.3" tomcatAuthentication="false" URIEncoding="UTF-8" />

<Engine name="Standalone" defaultHost="localhost" debug="0">

<Host name="localhost" debug="0" appBase="webapps" unpackWARs="true" autoDeploy="false">

<Context path="/confluence" docBase="../confluence" debug="0" reloadable="false">

<!-- Logger is deprecated in Tomcat 5.5. Logging configuration for Confluence is specified in confluence/WEB-INF/classes/log4j.properties -->

<Manager pathname="" />




When trying to get to the confluence/ site I get a 403 access denied error

I have placed a phpinfo file in there and php details are output. I therefore know that there is not a rights issue.

Any ideas, I have tried clearing logs, resetting browser cache, driking copious amounts of coffee and still i cannot access. Is there anything that can be stripped out of the server.xml


1 answer

1 accepted

0 votes
Accepted answer

Hi Steve, personally I really hate AJP, I lost my temper many times with it... then my live changed when I discovered ARR, you can see how this configuration is set here. It says JIRA there, but the steps are exactly the same for Confluence.

I hope it helps.


Thanks I will give it a go. And let you know

Edit: so in the connector line on bullet 5. Where does port=8080 come in. Should it be 8090 for confluence?



Hi Steve, yes. It's correct, just edit the port to use the one configured in your Confluence server.xml. You may also need to adjust the Rewrite URL to match your Confluence URL


ok, i can now access it externall but irt does not seem to render correctly. All i get is the below.

It seems that the CSS of the page is not rendering, I saw it happening in the past and the problem was related to the parameters proxyName and proxyPort missing in the server.xml file (step 5 here). You may want to double check this setting, remember that you need to restart Confluence in case you need to edit any configuration file.


I noticed that i had not updated the rewrite path to reflect the correct location.

In the end, soooooo much simpler than AJP> IT may be worth changing the recommendation to use AJP is this method is much easier and it also uses standard Microsoft addons.



Hi Steve, I couldn't agree more with your suggestion, I opened this request to update our docs: https://jira.atlassian.com/browse/CONFDEV-26221

If you thing this question was answered satisfactorily, you may accept the answer, this will increase its visibility and may help others in the future.



Thanks for the advice, and again, so much easier to use than AJP. It just works.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Canada

Happy New Year - First AUG of the year - great success

Hi Everyone, Hope everyone had a great holiday season and is ready for an exciting 2019.  We had our first AUG last night featuring Tempo Timesheets.  A great presentation and lots of int...

15 views 0 1
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you