[Tempo] - Disable period autoclosing Edited

Hi there,

How can I disable the period autoclosing at the end of the month in Tempo?

I'm not using the Tempo Scheduler, it's disabled, and I don't want to use it with the grace period.

 

Thanks in advance.

Best,

 

Bastien

2 answers

We had the same issue. I wonder if this is a bug. Assuming that is the case, we I did was "Enable Tempo Scheduler", then clicked "Edit" next to "Operations", and unchecked the "Make Scheduler Close" option. Then I disabled the Tempo Scheduler again for good measure. Until the end of the month I won't know if this will fix it yet.

Hi, we are also having the same issue, has this been confirmed as a bug or something else?

how can we fix it?

Thanks.

Sure seems like a bug. The steps I went through above did NOT fix it.

I don't think it's a bug, but a missing feature. The Tempo team has indicated that the Scheduler and the Period Manager are not connected in this way.

So it looks like they're just missing a feature to allow you to disable the auto-closing of periods on the Period Manager.

That is incorrect, Travis. The comment you linked to and the relevant documentation is explicit that the Period Manager is managed manually. There is nothing in the Period Manager documentation that says it auto-closes periods. Indeed they are not connected, and only the Scheduler is responsible for auto-closing the ability for users to register hours in the timesheets, so it is the Scheduler that has the problem.

That or the documentation or UI is confusing. It wouldn't make sense to disable auto-closing of periods in the Period Manager because there's nothing indicating it does so to begin with.

I may have a reply that posts 3 times....my reply keeps disappearing...

EDIT: It stayed now that I split it into two replies. More bugs @atlassian

When my periods auto-close, I fix it by going to the Period Manager screen, where it indicates that the period is closed, and I change it to Open.

Based on the previous question/answer that I linked to, it seems that there are two different ways to close a period. Using the Period Manager, or using the Scheduler. And these close the period in different ways. If either is closed, the user will not be able to log time.

For me, the scheduler has always been disabled. It sounds like your assumption is that even when disabled, the scheduler still auto-closes periods (which would be a bug). I think this is incorrect.

Here are the scenarios I'd want to test out:

  1. Scheduler disabled
  2. Scheduler enabled, auto-close turned off
  3. Scheduler enabled, auto-close turned on

We've all seen what happens in scenario 1 above...the period gets closed, the timesheet is grayed out for that period, and the Period Manager screen shows the period as closed.

The question that I previously linked to demonstrates scenario 3. The OP had the scheduler enabled with auto-close turned on...the period gets closed, they didn't indicate what the timesheet looked like for that period, but the Period Manager screen shows that the period is still open.

My current setup will test scenario 2, but we won't see the result for a month. My expectation is that the result will be the same as scenario 1.

 

Given that scenario 1 shows the period as Closed in Period Manager and scenario 3 shows the period as Open in Period Manager (but users still can't enter time), it seems more likely to me that there is an undocumented feature that auto-closes periods in Period Manager, and no option to disable it.

Hello!

We have exactly the same problem with autoclosure of month. Is it a bug?

Did you find a method to fix this issue?

Yes, Kate, it seemed to be Bug

The bug with the period closing automatically in the Period Management has been fixed on  Timesheet 8.4.1

We to had the same issue, So upgrade fixed it.

And yes also have a look at Release notes and Proactive actions before the upgrade.

Have the same bug on 8.7.0. Scheduler is off. May be there is another reason for auto-closing period? 

Yes, Kate, it seemed to be Bug

The bug with the period closing automatically in the Period Management has been fixed on  Timesheet 8.4.1

We to had the same issue, So upgrade fixed it.

And yes also have a look at Release notes and Proactive actions before the upgrade.

Thanks for your respond!

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

358 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you