Jira Plugin Upgrade

Dear All,

I have developed a Jira Plugin on 4.3.4 version. Now I want to upgrade my plugin on 5.x.

Could you help me someone how should I start.

One more question can I develop both the plugin in same PC.

With Regards,

Tapas

2 answers

0 vote

Developing it on the same machine is more a question for how you do your version control - you're going to need different files for it, but I'd simply make sure I've got "latest release version for 4.3.4" tagged/labelled/whatever and then just launch into the work for v5.x in the same place.

We don't know your development environment or how you wrote your pluging, so everything else is a bit fuzzy, but, assuming that you have tagged as above, and that you are using the Atlassian SDK, all you need to do is

  1. Amend the pom.xml to point at Jira 5.x
  2. Run atlas-clean to hoover out the older test installations
  3. Open the plugin in an IDE and check and fix the dependencies and API stuff it tells you have changed
0 vote

Developing it on the same machine is more a question for how you do your version control - you're going to need different files for it, but I'd simply make sure I've got "latest release version for 4.3.4" tagged/labelled/whatever and then just launch into the work for v5.x in the same place.

We don't know your development environment or how you wrote your pluging, so everything else is a bit fuzzy, but, assuming that you have tagged as above, and that you are using the Atlassian SDK, all you need to do is

  1. Amend the pom.xml to point at Jira 5.x
  2. Run atlas-clean to hoover out the older test installations
  3. Open the plugin in an IDE and check and fix the dependencies and API stuff it tells you have changed

Hi,

FYI, Your answer got posted twice for some reason.

(pom.txt)

Thanks for your response. I am attaching my pom.xml. getting error:

"Project build error: Non-resolvable parent POM com.atlassian.jira.plugins:atlassian-jira-rpc-parent:5.0.6 for com.kovair.jira.plugins:kovair-jira-plugin:1.0.1: Failed to resolve POM for
com.atlassian.jira.plugins:atlassian-jira-rpc-parent:5.0.6 due to Missing: ---------- 1) com.atlassian.jira.plugins:atlassian-jira-rpc-parent:pom:5.0.6 ---------- 1 required artifact is
missing. for artifact: com.atlassian.jira.plugins:atlassian-jira-rpc-parent:pom:5.0.6 from the specified remote repositories: central (http://repo1.maven.org/maven2, releases=true,
snapshots=false)"

please help.

I'm afraid I'm a bit stuck on that one - I don't know whether that dependency should exist at all, or why it's not resolvable.

I'm really not an expert on pom.xml files, but when I've been stuck upgrading a plugin, I've used atlas-create-jira-plugin to create an empty skeleton plugin somewhere else, moved my old pom.xml out somewhere safe, and put the newly created skeleton pom.xml in place. Then built it up piece by piece by referring to the old one. That should at least narrow down where the error is coming from (but I still suspect the rpc parent it's looking for simply isn't there)

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

252 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you