Confluence Documentation Theme - Upgrade question

Hello

We use "Documentation theme" https://marketplace.atlassian.com/plugins/com.atlassian.confluence.plugins.doctheme for confluence.

The site says it only supports to 4.1.1 , does that mean I am stuck in the year old version? Since this is a quite a popular plugin are all the users who use this plugin should stay at the older version of confluence and not upgrade?

Please let me know what I should do to upgrade to current version of confluence.

Thanks

Abe

3 answers

1 accepted

0 votes
Accepted answer

There is a documentation theme bundled with Confluence already. I do not know how it compares, but it worth a look.

https://confluence.atlassian.com/display/DOC/Using+the+Documentation+Theme

Here is the link for the 4.3 release verses future releases. This double documentation is a real pain.

https://confluence.atlassian.com/display/CONF43/Configuring+the+Documentation+Theme

I found this note, so now I feel really confident to state the documentation theme is bundled with Confluence now.

The Documentation theme is bundled with Confluence 3.2
The Documentation theme is shipped as part of Confluence 3.2 and later. See the guides to configuring the theme and using the theme.

https://studio.plugins.atlassian.com/wiki/display/DOC/Confluence+Documentation+Theme

I've got this same issue. Abraham, did you figure out how to resolve it?

I did not have to change anything the included theme worked for me... Are you using custom themes?

I am currently at Confluence 4.0 and would like to upgrade to a more current version. The compatibility checker in Confluence says that the Documentation Theme is not compatible with Confluence 4.1.2 onwards. If I disable the Documentation Theme in Confluence 4.0 our spaces (most of them) that use that theme no longer render properly. Thoughts?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in Marketplace Apps

How to set up an incident workflow from the VP of Engineering at Sentry

Hey Atlassian community, I help lead engineering at Sentry, an open-source error-tracking and monitoring tool that integrates with Jira. We started using Jira Software Cloud internally last year, a...

1,701 views 3 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you