Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


{{issue.comments.last.body}} not working correctly in HTML email notifications.


We are using Automation for JIRA SD cloud and I have currently setup alert email notifications that are set to be HTML.  I'm using {{issue.comments.last.body}} within the body of the email and it is not coming through correctly even though everything is set as HTML.  Only the {{issue.comments.last.body}} field appears to have this issue.   The email come through ok with the other components but as soon as that field value is placed within the email it is showing all HTML tag/formatting as text for any values of that field.

Have you seen this before?  

Thank you,

3 answers

Very late comment on this item but I came across it whilst faced with the same issue.  In case someone else follows the same path, I ended up using the below which worked as expected:



NB I needed to uncheck "Convert line breaks to HTML line breaks" to ensure spacing was as desired.

This worked perfectly!

Are your emails displaying something like this?


{color:#fdsgds} Hi there {quote}

{quote} {quote}


When it should look like this:


Hi there


If that's the issue you're having, I'm having the same thing and ended up using


That just replaces anything surrounded with { } and it's contents. Works for us as long as no one uses curly braces in their email (which I've never seen before)



0 votes
Deleted user Oct 10, 2017

I haven't seen this before but mail clients showing HTML source rather than processed HTML usually occurs if the HTML isn't valid.

Since the comment is used directly by default, you could try escaping the comment? Something like:


should do the trick

Thanks for the reply Mark,

I gave this a shot and unfortunately it was still coming through in the same manner.   I've just changed everything to standard text for now to clean it up.  



Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events