Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,038
Community Members
 
Community Events
176
Community Groups

XRay - Import Cucumber Execution Results with Multipart

Hello, 

I'am trying to import my cucumber execution results into XRay via. the REST API / cucumber-multipart and want to change the summary of the new created test execution in Jira.
What i do:

1. Export feature files from Xray into Java Project
2. Execute my tests
3. result.json is generated from Cucumber
4. I generate a info.json for multipart to edit the summary of the test execution
5. HTTP post request with Content-Type: multipart / Formdata 

But the only response i get from Xray is:
Responsecode 400: Bad Request - "error": "The result file is required".
I don't understand why i get this response, i deliever the result file?

- My result.json looks like a standard cucumber result Json File
- My info.json looks like:
   

{
"fields": {
"project": {
"id": "14335"
},
"summary": "Cucumber Test Execution",
"components" : [{
}]
}
}

- First i tried to send the post request from my java code than i also tried to use postman for testing purpose
- Infos about my HTTP POST Request:

POST /rest/raven/1.0/import/execution/cucumber/multipart HTTP/1.1
Host: xxxx
Authorization: Basic c2...==
Content-Type: multipart/form-data; boundary=----WebKitFormBoundary7MA4YWxkTrZu0gW
Cookie: xxxx
Content-Length: 444

----WebKitFormBoundary7MA4YWxkTrZu0gW
Content-Disposition: form-data; name="resultFile"; filename="resultJira.json"
Content-Type: application/json

(data)
----WebKitFormBoundary7MA4YWxkTrZu0gW
Content-Disposition: form-data; name="infoFile"; filename="resultInfo.json"
Content-Type: application/json

(data)
----WebKitFormBoundary7MA4YWxkTrZu0gW

Can somebody help me with this?

Thanks in advance,
Greetings Simon

 

 

 

 

    

 

 

 

1 answer

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events