Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,464,704
Community Members
 
Community Events
176
Community Groups

XRAY: Works the Gadget "Requirements List" with different projects?

Edited

Hi,

I have the following set-up:

-one project A for test (test, executions, testplans, testsets)

-one project B  for requirements (epics, stories)

like its written here: https://docs.getxray.app/display/XRAY/Project+Organization+Use+Cases

The links from test to requirement are working (project A to project B).

I want to use the gadget "Requirement List".

story.jpg

Here is the problem:
The column  "status" of the story is shwon as "NOTRUN". The column "total" shows the number of testcases which are linked to the story, what is ok.

I executed the testcase (Result: PASS) in project A. The story is based in project B.

If I klick on the story name, the story opens and the requirement status shows "OK" (which is the right status).

Is there a possibility to update the status-column in the "Requirement List", or is it only possible if the execution and story are in the same project? 

 

regards Chris

 

 

 

1 answer

1 accepted

0 votes
Answer accepted
Stefan Salzl Community Leader Feb 07, 2022

Hi @Christoph Korittke ,

could you please provide some more input in order to analyze this problem?

it would be helpful to have

screenshots

  • of the testCase in project A
  • of the testExecution in project A
  • XRAY project settings (summary or coverage) of project A
  • Story in project b
  • XRAY project settings (summary or coverage) of project B

 

Best
Stefan

Hi,

thanks, I updated my description.

Like Stefan Salzl likes this
Stefan Salzl Community Leader Feb 08, 2022

Could you check/screenshot the configuration of your gadget? Maybe there is a filtering on an entity (eg. version) where there hasn´t been any test-execution logged?

I reproduced your setting on my site (but have to add it´s a cloud site) and it works well (see screenshots).

 

image.pngimage.pngimage.png

Like Christoph Korittke likes this

Hi,

thanks for your effort.

I see your Requirement has the key RP, and the test the key JT.

So this are different projects.

But where is the test execution from testcase JT-20? in which project is it based, in RP?

 

 

I think this is my problem...wehen I use in a "free-play-project" the issues:  test,

test-execution, story in the same project the "Requirement List" is working.

Hi,

I remanaged my filters in the gadget.
Testenvironment was wrong, now it works fine.

Thank you.

Like Stefan Salzl likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events