Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,464,990
Community Members
 
Community Events
176
Community Groups

Universal Plugin Manager will not update

We are running 4.3.2 of Confluence and we have not been able to get the Universal Plugin Manager to finish it's update. Once I click on the Update Now! link it starts but just sits there and never finishes. I have to eventually reboot the serer to get the update progress off the screen. I'm not sure what to do here.

5 answers

1 accepted

5 votes
Answer accepted

You did not say what version of UPM you are running, or whether anything was recorded in the log, but if you have UPM 2.7.8 or 2.7.9 then there is a known bug...

https://confluence.atlassian.com/display/CONFKB/UPM+Self-Update+fails+when+updating+from+UPM+2.7.8+or+2.7.9+to+newer+versions

...and you have to upgrade manually:

https://confluence.atlassian.com/display/UPM/Updating+the+Universal+Plugin+Manager#UpdatingtheUniversalPluginManager-UpdatingUPMbyfilereplacement

It is version 2.0.6.

I've tried to manually update this with three different options and they all hang.

plesase try the second link mark pointed at...

read "Updating UPM by file replacement" for Confluence and you should be able to proceed...

currently using version The Universal Plugin Manager (v2.0.6) by Atlassian

I've tried the manual option and it has failed, it seemed to timeout here are the last part of the logs from a July 29th attempt.

  • 2013-07-29 19:35:39,392 ERROR [http-172.16.120.130-443-46] [internal.util.concurrent.RunnableTimedExecution] execute Closing runnable for context NonValidatingOsgiBundleXmlApplicationContext(bundle=com.atlassian.confluence.extra.team-calendars, config=osgibundle:/META-INF/spring/*.xml) did not finish in 10000ms; consider taking a snapshot and then shutdown the VM in case the thread still hangs

Have you logged a support call with Atlassian about this?

The following is something that might not be safe and should be confirmed with a better authority than me first (such as Support).

When you say that you've tried the manual option, did you try using your plugin servlet to first uninstall the old UPM version? If so, it might be necessary to then..

  1. stop the Confluence server
  2. restart Confluence
  3. Use the plugin servlet again... this time to manually upload your new UPM jar.

The reason I suggest this is because your "did not finish in 10000ms" error is for team-calendars and not for UPM. It looks *very* much like the kind of errors that I have seen from a JIRA server that is slow in shutting down (logged here as JRA-22070). Note the "shutting down". I would imagine that your Confluence was shutting down when this error was logged.

Anyway, if we are looking at the same sort of problem, the linked JRA-22070 explains that the Team Calendars error is being caused by a problem in one of the other plugins. And for you that may well be your problem UPM. If it cannot stop properly than that might be what is making it impossible to upgrade it.

By the way, for me, JIRA never did shut down when I had the problem. I had to kill the JIRA process. And you might have to do that too for Confluence (at least until UPM is fixed). As soon as I found my problem plugin and disabled it, all the "did not finish in 10000ms" errors went away.

I'm having the same problem in Jira Software (Server) taking this plugin from 5.1.2 to 5.1.5. It tells me the update is available, but then it fails and tells me to check the log. It doesn't say what log or where to find it, so I went to the audit log, where it shows messages like this:

App Upgraded:

Method:Unknown

Version:

  • +5.1.2

App key:com.atlassian.upm.atlassian-universal-plugin-manager-selfupdate-plugin

 

App Enabled:
Method:Unknown

App key:com.atlassian.upm.atlassian-universal-plugin-manager-selfupdate-plugin

Version:5.1.2

no results, i already tried it in the past.

But i found another usefull post after i wrote mine here.

The Problem was the MySql Database

max_allowed_packet

i changed the parameter in my my.cnf file to 32MB and the update worked fine :-)

The JIRA universal plugin manager has been updatet manualy in the filesystem, cause i did this first.

Now both Update Manager up to date

i also had the same conditions, Confluence 4.3.2 and UPM v 2.0.6

i also can't install and update other plugins.

Everytime i try i get the red error report that i should look in the logs.

But in which log files should i look?

On my Server i searched via "fgrep -Rli 'universal plugin'" and nothing has been found in any logfile.

i need to solve the problem.

what about

grep universal /opt/atlassian/jira/logs/catalina.out

adjust the path and see what you'll get

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events