Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,736
Community Members
 
Community Events
176
Community Groups

Insight: Filter data source by IQL not working

I have what I think is a very simple filter on my csv import, but I get an error when try to import: "import data mapped to OTA label is empty".

My filter is Cat = Add-on.  When I remove the filter the import does not have an error.  Filter and simple configuration screenshot below.

image.png

I have tried many different ways but cannot get this filter to work.  Using Insight 5.5.14.1.  Thanks, - Paul

 

1 answer

1 accepted

3 votes
Answer accepted

OK, have found my own answer (wish I had before posting this!).  filter must be Test=Add-on (not Cat = Add-on)  I thought left side had to be data source field, but apparently is the Insight field.  And that works.

Having fun trying to get this working.

 

I want to import all the models from the asset spreadsheet refined by Manufacturer = Apple but any time I filter it doesn't work :(

 

Screenshot 2019-06-12 at 16.08.47.pngScreenshot 2019-06-12 at 16.10.42.png

@Steve Letch , I think the problem you're facing is the same one I just figured out after a few days of banging my head against the wall:  according to https://documentation.riada.io/display/ICV70/General+Import+Concepts, it's not possible to use the Filter data source by IQL feature to filter referenced objects.  In Paul's case, I'm guessing that Test was a text field.  In your case, it looks like Manufacturer is a reference.  

 

In my case, I'm trying to filter by "Operating System" Like Server, but Operating System is a reference.  My workaround will be to add a field named OS Name that will be a text field, run a periodic bulk update of OS Name to be the same as "Operating System"."Name", and update my import to filter by "OS Name" like Server.

@Jon Hill I had an hour long screenshare with the makers of the plugin so have a much better idea of how it works now.

 

I now have a really sweet Insight setup with users and devices cross referncing all sorts of things.

 

I also have a nice LDAP sync going which pipes into the Service Desk tickets.

If you need more clarification on their slightly confusing ways i'll post a bunch of screens and attribute examples on monday from the work lappy

Like # people like this

Thanks for hint! Run into same issue with referencing IQL filter, but thanks to this thread, solved in the minutes by creating Hidden atribute. Thanks guys. 

"hiddenEnvt" NOT IN ("LINUX","STORAGE","RSA","IOS","OS400","VMWARE","WIN","UNIX","Z/OS")

 

Also fails when there are not values within that set trying to load a csv file. The rest of mapping-impots conditions like "hiddenEnvt" = "LINUX" work fine

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events