Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,465,489
Community Members
 
Community Events
176
Community Groups

How can I embed an existing draw.io diagram into Confluence from Github?

I bring up the macro, select Github and enter what I would think are obvious values, but it continually tells me diagram cannot be found or cannot be accessed. I cannot find any relevant documentation from the app publisher on this. Has anyone else been able to get this working, and if so, what did you do?

Screenshot 2022-07-07 154759.png

 

 

1 answer

1 vote

Hi, 

Not sure what you typed into other fields, but take a look at the example I tested (which is working) and you'll probably know how to change inputs.

I took "link" diagram as an example from our GitHub https://github.com/jgraph/drawio-diagrams and filled the fields:

github.JPG

I assume filename you added wasn't correct but our label is not clear enough (we'll change that). Filename should include the path. 

Does this help?

Marija

Hi. I am getting a 404 on the github api. I am using an organization with private repository. Is there something else I need to setup? I am able to see your test example. But it cannot locate my github repository.

Hi Tim,

You also submitted your questions to our JSD and we replied there.

Kind regards,

Thanks. I got the connection to work. But requires each user that goes to a confluence page to authenticate with Github. I was told in a future version this experience will change for private repos. Not sure how that will work, but excited to see that I don't need to have my users all have a github account.

Hi Marija, I'm having the same issue as Tim.

I've authorised GitHub, and I'm trying to use a diagram from a private repo. The URL for the diagram in GitHub is https://github.com/jsayce/draw.io/blob/main/GcobLegacyCloud, so I've entered the following values:

image.png

The request to https://api.github.com/repos/jsayce/draw.io/contents/GcobLegacyCloud?ref=main&t=### gives a 404.

Am I doing something wrong?

Thanks,

Jon.

Jon, 

 

Have you tried putting  blob/GcobLegacyCloud 

in the path field? 

Hi Tim,

Thanks - just tried that - the request is now 

Hi Tim,

I've the same problem. Looks like they changed the token handling in the GitHub REST API[1], because it's now part of the HTTP Header and the plugin is passing the token in form of a query parameter as `&t=...` which is not part of the latest API any more :-/ 

[1] https://docs.github.com/rest/reference/repos#get-repository-content

Best,
Philipp

Hi Tim and Marija

Can we see this response from JSD?

I'm having the same issue as described above. Works as expected if the repo is public, but not private.

Is there a plan to fix the issue?

I really had high hopes for this plugin.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events