Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error in configuration of Zendesk Support for JIRA

image.png

Hello everyone,

I have been trying to integrate Zendesk Support with JIRA, but it seems like there is an error.

The image I uploaded in this question-article shows up when I press 'Configure' button in Manage apps page (under Zendesk Support for JIRA) in Jira Software. 

I have read about adding a dedicated user part, but that one also, I have not fully understand. 

I am literally lost at the beginning of this integration, so please help me :(

4 answers

1 accepted

0 votes
Answer accepted

@Sam Ahn @Dario B 

Updating CA Certs file has resolved this issue. 

After working with Zendesk support, they provided us with a debug plugin which output a PKIM error when connecting to the Zendesk Jira plugin url.

We ran SSLPoke from our JIRA server to the jiraplugin.zendesk.com and noticed the SSL handshake errors. The culprit appeared to be that Comodo changed their name to Sectigo, and our java cacerts file does not include those CA certs.

At some point Zendesk updated their SSL certs for the jiraplugin cluster and resulted in the plugin add on breaking. We updated our java certs file to include the required Sectigo certificate and restarted Jira.

We removed the debug plugin and added the Zendesk Jira Plugin and were successfully able to configure the Zendesk plugin. Functionality was returned once the authentication to Zendesk was completed in the plugin.

It would be beneficial for the plugin to natively output connection errors to help with resolving this issue.  

@Todd Bohling 

My error page is gone from now as well.

Zendesk team also thought that my issue was also about SSL and some plugin, but mine turns out to be related in old configuration.

There has been some old configuration left within the system and this was interfering the current setting.

Zendesk team solved this in their side, and now the configuration works fine for me.

Like Dario B likes this
Dario B Atlassian Team Nov 08, 2019

Thanks for letting us know @Todd Bohling 

Happy to know the issue is gone, I have accepted your answer to mark the thread as solved.  :)

 

Have a nice weekend!

Error:

Unable to connect to jiraplugin.zendesk.com from the JIRA server. Ensure your firewall is not blocking the connection.
Once the connection issue has been resolved, you will need to reinstall this add-on.
For more details refer to this article.

Solution that work for us:

The problem was associated with the SSL certificate that Zendesk has for the domain: jiraplugin.zendesk.com with the CA Sectigo.

Comodo was one of the major CA and almost all the applications has Comodo as root and intermediate CA, however, Sectigo bought Comodo.

After this happens, many applications that doesn’t have sectigo installed have problems. Jira doesn't have Sectigo.

We solved it in our end adding Sectigo to our certificates however found the root cause of the issue was difficult and incur in expend a lot of resources either from Equisoft, Zendesk and Jira team.

The best way to fix it to all Jira customers is to add  CA Sectigo to the list of CA certificate preloaded in the application. Otherwise, any customer that will run Jira without Sectigo CA will have the same issue.

From our end it is fixed however We suggest you to add CA Sectigo

 

How to add the certificate:

Download and install the Portecle app onto the server that runs Jira.

follow steps on page:

https://confluence.atlassian.com/adminjiraserver/running-jira-applications-over-ssl-or-https-938847764.html

 

Download sectigo intermediate Certificate:
https://support.sectigo.com/articles/Knowledge/Sectigo-Intermediate-Certificates

Jira.jpg

Hi @Sam Ahn 

I'm not sure about the Atlassian Jira Zendesk connector.

However, if you're still lost (and looking for an alternative), we are the developers of Exalate, a synchronization solution for Jira and Zendesk. Maybe this might be a better fit.

But if you don't mind me asking, what are you trying to achieve with the Jira - Zendesk integration exactly? What's your use case?

 

Btw, you can find Exalate for Jira on the Atlassian Marketplace here. And Exalate for Zendesk on the Zendesk marketplace here. In case you would like to try it out for yourself.

0 votes
Dario B Atlassian Team Oct 03, 2019

Hi @Sam Ahn ,

Welcome to the Atlassian Community!

Can you kindly let us know which documentation you are following and what is failing so that we can try to assist? 

Cheers,
Dario

Hello @Dario B 

https://support.zendesk.com/hc/en-us/articles/203660196-Jira-Setting-up-Zendesk-Support-for-Jira-integration

This is the link I am following mainly, and checking lots of related articles mentioned in the above one. 

The part I am facing an error happens when I press Configure button in Manage Apps, under the drop down menu of Zendesk Support app.

I thought of adding the dedicated user for Jira, but having problem with that too. 

I think I am totally lost, so probably every step in detail might help me greatly.

Thanks :)

Dario B Atlassian Team Oct 04, 2019

Hi @Sam Ahn ,

Thanks for pointing to the documentation. I have gone through it and I can indeed confirm that the part about creating the user is a bit confusing.

I believe the add-on user is the one that gets created when configuring the integration, however, since I am not familiar with this add-on I need to do some testing to see if I manage to make it work of if I get the same error you get. 

 

Now, just to make sure I have a correct understanding, are you getting the error on step #7 when you click on "Configure"  or on step #9 when you click on "Authenticate"?

Zendesk-integration.jpg

 

Please let me know.

 

Cheers,
Dario

Hello @Dario B 

Thanks for your detailed check.

I am having my error after step 7. When I click configure, the image I attached in my inquiry shows up and nothing happens after that. 

 

Thanks again for the help :)

Dario B Atlassian Team Oct 08, 2019

Hi @Sam Ahn ,

If you get the issue on step 7, before actually even getting to the configuration screen, then something is wrong with the instance.

It can either be the case that something is wrong with your license, or with the add-on key or anything similar. However, in any case, the best way to proceed it's to open a support request by using below link:

 

This is because I don't have any way to check the logs for your instance while the support team,  having an open request, will be able to access your instance, reproduce the issue and check the logs to see what is happening.

 

Cheers,
Dario

Thanks for the help @Dario B :)

Like Dario B likes this

You are very welcome @Sam Ahn !

[EDITED]

UPDATE: I have found the support request and apparently the problem is not with the instance since we actually receive error 500 (Internal Server Error) back from the app vendor side (https://jiraplugin.zendesk.com/.....).

In this case you will need to get in touch with Zendesk Support by using the link listed in the "Support" tab of the marketplace page for the add-on:

 

Cheers,
Dario

@Dario B 

Thanks for your catching up. I was about to reply you that issue I received.

It's been such a great help, at least now I know whom to contact. :)

Thanks again!

Like Dario B likes this
Dario B Atlassian Team Oct 10, 2019

You are very welcome @Sam Ahn ! :) 

Unluckily the issue was not on our side but at least now we know what is happening. Zendesk support should be able to help from now on. 

Have a nice day!

Dario

@Dario B @Sam Ahn 

I am experiencing the same issue where we cannot successfully get the configure screen to render.

Our message in Jira ticket under Zendesk Support is:

Unable to connect to Zendesk Support

Seems that there is a problem, please ask your admin to reinstall the add-on.

When we click Configure we get this message:

Unable to connect to jiraplugin.zendesk.com from the JIRA server. Ensure your firewall is not blocking the connection.
Once the connection issue has been resolved, you will need to reinstall this add-on.
For more details refer to this article.

We have done extensive troubleshooting around any networking changes or configuration changes.  Nothing appears to be incorrect.  We can successfully curl the zendesk server from our instance. This was working prior to October 4th 2019.

We have been actively working with Zendesk support since Monday.

We are connected to pod14 for the jiraplugin service.

If you find any updates, please post.

Like Dario B likes this
Dario B Atlassian Team Oct 11, 2019

Hi @Todd Bohling ,

Thanks for adding more details.

Unluckily I cannot reproduce the issue locally so I am not going to be too useful here.  However, since you are already in touch with Zendesk support, you may actually be the one that could  add some updates on this issue to this thread. :) 

Let us know if they get back with any finding or test to perform from our side.

 

Cheers,
Dario

@Sam Ahn did you get this working?

@Todd Bohling 

Not yet. Zendesk team is working on this error, but haven't received the right answer yet. Will share the result in here for others who are going through the same thing as me! :)

Like Dario B likes this

Likewise we are working through a case with Zendesk and hope for resolve soon.

We go through this error every few months and have to remove the add-on completely, remove it from the file system, then restart jira, then re-install the add-on. It's a very frustrating process. I wish Zendesk would put some time into fixing it (and supporting multiple Zendesk environments to one jira instance). 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Apps & Integrations

🍻🍂Apptoberfest Update: Upcoming Virtual Events 🎉

Hello Community! I hope you've been enjoying the 🍂Apptoberfestivities🍂 (I know I have!) The event is heating up next week with a series of virtual events that we're calling the 🍻🍂Partner App ...

394 views 3 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you