Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,520
Community Members
 
Community Events
168
Community Groups

Connecting Slack to On Prem Jira not working

I cant get the Slack JIRA Server connected it just throws an "Oops" message.

We have a JIRA set up as https://jiraserver.domain.com:8080, could the non-standard port be the reason? I dont have the possibility to change this easily so was hoping there would be some other solution.

thanks,

Johan

2 answers

1 accepted

0 votes
Answer accepted
Daniel Eads Atlassian Team Dec 20, 2021

Hi @Johan Johansson !

The integration should work on a custom port. For example, if the application is served over port 8443 and the URL is specified as https://jiraserver.domain.com:8443, then the integration should work.

However from the documentation, there are two important considerations:

  • The certificate must be signed by a public authority (e.g. Let'sEncrypt), NOT self-signed
  • To create a full connection (not a limited connection), the port must be open to the internet

Looking at your URL, I see that HTTPS is specified in the URL. But - it's on port 8080, which is actually the default non-encrypted port for Jira. I would want to double-check that both conditions are true. You could use the geocerts SSL checker for your URL and port to ensure everything is in good shape. Let us know the results of that test!

Thanks,
Daniel | Atlassian Support

Thanks Daniel, in the end it started working, but not sure if the cert was the problem (but I did install the bundle cert as well before it started working)

If I initiated the integration from JIRA it worked fine (I tried to do it from the Slack admin page where it just complained that the connection couldnt be made).

So to sum up, as your answer lined out, custom ports are not a problem :)

Best regards

Johan

Thanks Daniel, yes we use 8080 despite SSL as some of our customer had to punch holes in thier enterprise proxies so we wanted to keep the port number. Anyway I get green on all SSL tests but ”

Certificate Chain Complete?” where it says I should install a root cert (I use a namecheap ssl cert so not self-signed). Could that be the reason?

thanks

Daniel Eads Atlassian Team Dec 20, 2021

It's a possible reason - I would normally refer to the Qualys test at https://ssllabs.com to see what handshakes pass. However, SSL Labs doesn't support testing on non-443 ports. Slack's own documentation also suggests SSL Labs for testing.

Typically it's an intermediary cert that causes issues - for example, many GoDaddy certificates use an intermediary that's not in the trust chain for certain older versions of Java, so that intermediary needs to be included.

If you are able, adding whichever certificate geocerts suggested to the chain would be a next-step. 

Although namecheap does have some bundles listed on their site, they also seem to suggest reaching out to their customer support to get the correct bundle.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events