Websudo administration access screen requests authentication with each page refresh

Hi,

When ever I try and make changes to my configuration to my Jira installation through the admin pages I am prompted to authenticate my administrator account with each page refresh. I have checked and I did not have any settings for the websudo timeout and I then tried to set the websudo to 10 mins, which is technically the default and I am still having the same issue.

6 answers

1 accepted

I'm not using crowd. I believe I found my issue(s). When I configured all my applications sitting on the same box I put them all under the same path using different ports, such as:

Jira = http://server:8080

Confluence = http://server:8090

Fisheye/Crucible = http://server:8060

Bamboo = http://server:8085

When I ran just Jira and Confluence I found that was causing issues, so I thought maybe it was that since it was probably the only thing in the instructions I didn't follow. So I changed confluence to use the path http://server:8080/confluence and everything seems to be working fine now.

Thanks for the help.

Glad I helped, what no up tick?!

What is an up tick?

No, I don't believe so. I have looked in the User Sessions in the Administration->Security section and it seems to create new sessions for me all the time. Right now I'm looking at about 12 sessions with my username, even though I have only accessed Jira in one browser and one tab.

Although I am logged into confluence, fisheye/crucible and bamboo, I'm not sure if that creates other sessions or anything.

I also seem to have the same issue with Confluence.

did you make any interaction with JIRA as admin in other tabs/browsers between those page reloads? Ive noticed this behaviour too, specifically in JIRA.

Isolate to an application, run One app, trigger websudo, repeat activity, if it doesnt re-request auth, login to the next app, then validate the second app websudo, then try first. If there is an interaction that is breaking the websudo.

Are your apps all on different boxes on the same?

All the apps are on the same box.

The issue starts when confluence is started. I can force the admin access authentication if I refresh or browse a page on my confluence site. The admin access authentication also seems to happen at random even if I don't touch confluence.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Monday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

713 views 6 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you