How to resolve error ranking issues

I'm using Jira 6.2.5 with Jira Agile 6.4.0.6

When trying to rank issues on a kanban or scrum board, I receive the error below. This occurs on all issues and all boards.

"JIRA Agile cannot execute the rank operation at this time. Other users may be ranking the issues that you are trying to rank. Please try again later."

I found an article that suggested turning on validation-query in the ocnfiguration file and also checking database table AO_60DB71_ISSUERANKINGLOG for any unprocessed records. Neither of these 2 suggestions resolved the issue.

There is nothing written to any log file when this occurs.

I can't say for sure if this is what caused the problem or not, but it looks like the upgrade from Jira Agile v6.3.13.1 to v6.4.0.6 performed some upgrade tasks migrating the original Rank field to something called a LexoRank field.

"Starting upgrade task (buildNumber=44) : Migrate to LexoRank field"

Has anyone else encountered this and have a solution?

Thanks,

Doug

5 answers

Im having the same issue on my onDemand intance . Just started using it two days back and started importing issues into my instace from Mantis. Now that they are there when i drag things from the backlog into the sprint i get these errors as well as just simple reording

I'm having the same issue with OnDemand version using a scrum board. I can reorder in future sprints, but not with in the current one. I have tried reordering in Plan and Work layouts. Both give the same error. I am the only one in the production while this is happening.

I'm having the same issue. Any resolution here? Any workarounds? this is a pretty major issue if I can reorder my tickets.

I have been having the problem, but I just did a re-index (this time using the Background re-index option) and now I was able to reorder issues in the current sprint. I'm not if the background re-index did magic or a fix happened.

Thanks Dave. I'm glad you got your issue fixed. But, I have re-indexed several times since the problem started (all with the Background option) and still have the problem. I upgraded to the lates Jira Agile today (6.4.0.9), re-index after the install, with no change.

God save us, what can i do

i have the same problem when using the java api only on rank first. would be nice if someone from atlassian can comment on this case ? i mean it can not be that customers are left alone with such issues

i hope someone at jira reads this thread. it is a shame to get money from customers for support but when you submit a ticket you are referednto use this forum although answers can only given from some internal jira experts.

we use the java api and ranklast works fine and with rankfirst i get same error as others report here.

if this is the strategy for atlassian than i wonder how the future looks like. jira is a tool companies depend on and if it does not work it can have significant impact. i hope some support manager react on this and change the support policies. as we see nobody helped the customers on this problem.

0 vote

Hello Doug.

There is aknown bug reported and being worked on with high priority that I believe addresses your problem. Here is the link: https://jira.atlassian.com/browse/GHS-10872

There is a statement from the developers there as well.

I hope this can give you some light. Please note that there are some workarounds described there as well, so you could take a look to check if they work for you.

Cheers!

0 vote

As benito mentioned, please refer https://jira.atlassian.com/browse/GHS-10872. You should follow the work-arounds provided on this bug entry. Hope it helps!

Cheers

Luciano

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

229 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you