Getting an error customfield_10006 Epic with key does not exist when importing with attachment

When trying to import from Zephyr to Jira, and I try to map the attachement field to Epic Link  field in Zephyr, I get the following error:

{"errorMessages":[],"errors":{"customfield_10006":"Epic with key 'X:\\QA\\Defects\\RQM Screenshots\\Defect 4512.PNG' does not exist."}}

 

1 answer

Looking at the message it seems that the attachment field contains a path to a file, so this is not a valid Epic. Why do you expect that would work ?

Thanks for the Response.  I am new to JIRA.  We are trying to import from Excel to JIRA.  Imports without attachments work fine but when we have an attachment in Excel it is not working.  We have tried attachments as Hperlink and Object.  With Hperlink, we get an error and doesn't import at all.  But with an Object as an attachment, there is NO error and the import is successful but without the attachment.  Can you please suggest how we can import something with an attachment??

We are using zephyr to do this import from Excel to JIRA. Somehow we did the import with attachment once and unable to figure out how that worked. 

 

Can you  provide a sample of the excel file you're importing - probably you have some problem in the excel formatting. Would you also tell which importer you're using (a screenshot will work if you're not sure)?

Boris, thank you for responding.  We are using Zephyr (zfj-importer-utility-0.36.jar) for the import.  Here is the the screen shot of how we are mapping for the import

Zephyr_Mapping.PNG

 

 

Unfortunately when I try to attached the Excel Sheet (I clicked on  Insert Image where it showed an option to Upload files that I used to Upload the sheet), I get the error "Errors found in contents of the answer".  Can you please give let me know how I can send the excel sheet? 

I am new at this, so not sure what I am doing wrong.  

Some additional info:  Even though we get errors (See the screen shot) everything gets imported correctly except the attachment

 

You can upload the excel in dropbox or google docs and share a link.

I'm not really sure that the zephyr import uttility supports attachments - see this thread How to import test cases with "attachments" to Jira/Zephyr? It's a bit old, but I don't see support for attachments documented anywhere. You can try importing the attachments as a second step after you've imported all the test cases using the standard JIRA CSV importer

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

Looking for anyone who made the switch to Data Center

The Jira Marketing team is putting together an ebook on migrating to Data Center. We're looking for pro tips on how you staffed your project team and organized your Proof of Concept. Share yo...

35 views 0 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you