Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,119
Community Members
 
Community Events
168
Community Groups

Critical issue with restoring jira to cloud

Hi!

I have a major critical issue I hope someone can help with. I've created a support ticket, but there not that many agents on in the weekends and also the support site is down:

Long story short:

I've downloaded backup of Jira cloud to jira server, imported 66k issues from Fogbugz and uploaded back to cloud. I've done this  5-6 times, but today, when it's productive and 600 customers waiting for a new tool on monday, all attachments are mixed! I've looked in the attachments folder and everything is in the right place - so are they in Jira server, but in Cloud they are not in the right place. That means issue ABC-123 can see attachments from DEF-456 and so on(!!) This is a major security issue and if I'm not able to fix this by tomorrow I have to revert to backup from cloud and postpone the whole migration project.

Anyone experienced the same, and/or knows a ticket for this issue, hoefully with a solution?

1 comment

LarryBrock Community Leader Jun 03, 2019

Hi @Per-Åge Themte !

I'm sorry you're having trouble with the restore keeping track of it's attachments.  I'm sure there are others here with applicable experience but unfortunately, I don't have any advice to give other than to open an support issue with Atlassian, which you appear to have already done.

I do have a request of you - will you please post the solution here when you find it?  Thank you!

~~Larry Brock

Hi @LarryBrock ! Thanks for the reply! The issue was indeed achknowleded by Atlassian, but after nine months of prepping and multiple dry-runs, when we closed down the instances for 4 days and still had to revert to backup, we deciced to instead go for a clean cut between Fogbugz and Jira. I do believe Atlassian still investigates the issue, but won't be needing it. They do gave an option to solving this by using the REST api described here

...but it came 4 days too late...

Comment

Log in or Sign up to comment