Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

NullPointerException when trying to open edit workflow page in Jira

 

 

We got NullPointerException while trying to open "Edit Workflow" page in Jira Data Center version.

Exception log on webpage as follows:

org.apache.velocity.exception.MethodInvocationException: Invocation of method 'getHeaderHtml' in class com.atlassian.jira.plugins.workflowdesigner.action.WorkflowDesignerAction threw exception java.lang.NullPointerException at com.atlassian.jira.plugins.jira-workflow-designer:workflowDesignerApp//templates/workflowDesigner.vm[line 9, column 13] at org.apache.velocity.runtime.parser.node.ASTIdentifier.execute(ASTIdentifier.java:223) at org.apache.velocity.runtime.parser.node.ASTReference.execute(ASTReference.java:262) at org.apache.velocity.runtime.parser.node.ASTReference.render(ASTReference.java:342) at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:336) at org.apache.velocity.Template.merge(Template.java:328) at org.apache.velocity.Template.merge(Template.java:235) at org.apache.velocity.app.VelocityEngine.mergeTemplate(VelocityEngine.java:381) at com.atlassian.velocity.DefaultVelocityManager.writeEncodedBodyImpl(DefaultVelocityManager.java:117) at com.atlassian.velocity.DefaultVelocityManager.writeEncodedBody(DefaultVelocityManager.java:97) at

......

 

In log file:

/secure/admin/workflows/WorkflowDesigner.jspa [c.a.p.webresource.data.DataTagWriter] Exception encountered rendering data resource '[com.atlassian.jira.plugins.jira-workflow-designer:analytics-data]'
java.lang.NullPointerException
at com.atlassian.jira.issue.fields.config.manager.IssueTypeSchemeManagerImpl.getIssueTypesForConfigScheme(IssueTypeSchemeManagerImpl.java:316)
at com.atlassian.jira.issue.fields.config.manager.IssueTypeSchemeManagerImpl.getIssueTypesForProject(IssueTypeSchemeManagerImpl.java:263)

......

 

I tried to copy or delete a workflow (inactive), the operation was done, but the result page was showing similar error messages. In log file, following log were recorded:

/secure/admin/workflows/ViewWorkflowSteps.jspa [webwork.util.ValueStack] query="/headerHtml" {[id="null" type="5" values=""]} {[id="headerHtml" type="8" values=""]}

 

Any one know what's wrong here? Thanks.

1 answer

Hey @Bruce Liu , it looks like one of your Schemes connected to the workflow does not have an id, or an object within those, or the workflow itself.

To narrow it down further, try to swap other schemes connected to your project until you find the corrupted one. My guess is the workflow scheme, as the logfile states the nullpointer exception to occur at:

getIssueTypesForConfigScheme(IssueTypeSchemeManagerImpl.java:316)

If you have found it, you will likely have to either delete it for good using your db, or give it an id that is not yet in use.

Hope this helps somehow.

Thanks for replying, Andrej.

 

This exception happens to all workflows no matter used by any project or inactive.

In "view" mode, it will only show an empty page, in "Edit", it will show the exception message.

 

Cheers!

If you create a new Workflow, does the same behaviour occur?

Do they share a specific status?

Did anything change within your environment, that could cause this behavior to suddenly occur? (e.g. an update, license renewels being due or installing an app?)

Same error happens when creating new workflow:

ERROR [c.a.j.web.servlet.InternalServerErrorServlet] {errorId=091efc1f-adc8-49ce-86e5-a700ae8b5f9c, interpretedMsg=, cause=java.lang.NullPointerException, stacktrace=java.lang.NullPointerException
at com.atlassian.jira.issue.fields.config.manager.IssueTypeSchemeManagerImpl.getIssueTypesForConfigScheme(IssueTypeSchemeManagerImpl.java:316) [classes/:?]
at com.atlassian.jira.issue.fields.config.manager.IssueTypeSchemeManagerImpl.getIssueTypesForProject(IssueTypeSchemeManagerImpl.java:263) [classes/:?]
at com.atlassian.jira.issue.fields.config.manager.IssueTypeSchemeManagerImpl.getIssueTypesForProject(IssueTypeSchemeManagerImpl.java:269) [classes/:?]
at com.atlassian.jira.project.ProjectImpl.getIssueTypes(ProjectImpl.java:122) [classes/:?]

 

This is a new cluster that has done some migration work. Some plugins were disabled due to not in use any more. I have tried to enable all plugins, but the issue remains.

Bruce, have you been able to solve this issue?  I have a newer installation of Jira, 8.5.4 and we have performed a bunch of project imports from a different installation that had many workflow customization and now we can no longer create new projects or create any workflows due to the same NullPointerException you have.

Thanks

Hi Dan, it appears to be some plugin data corruption in our case, maybe you can look into the same direction.

I get the same problem with Jira 7.13.11 Datacenter. I ran a script that change the workflow scheme on specific projects so that we can retire custom workflows. Didn't any problems on the first test runs, the problem came out later.

Any updates? We are struggling with the same problem with Jira DC 7.12
Thanks
Arnold

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase

The benefits of using Jira in different departments

Jira is a great tool to use across different departments. Forget that paperwork – switch to Jira and get that tasks done smoothly. Marketing Jira allows for a complete digital transformation of you...

97 views 0 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you