Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,360,171
Community Members
 
Community Events
168
Community Groups

Metadata unknown during ticket creation in another project with an automation rule

Hi all,

I try to copy a ticket from my team-controled project into another team-controled project based on a change in the status of the ticket.

My issue is that when the rule is executed, I have an error :
"Metadata unfound in project/ticket type : 10003 / 10009"

I don't know how to identify the metadata property of all the properties of my project.

For the test, I created 2 brand-new team controled project (without any customisation). I re-create the same automation (creation of a ticket with copy of the description in project 2 when ticket is status done in project 1). I got the same error with the same metadata code...

Thanks for your help !

2 answers

0 votes

Hi @Sambath SUN 

For a question like this, it may help to post images of your complete rule and the audit log details showing the execution.  That will provide context for people trying to help.  Thanks!

Kind regards,
Bill

0 votes
Pramodh M Community Leader Aug 26, 2022

Hi @Sambath SUN 

When you copy an issue via Automation rule, you might have to specify the fields which you want to copy.

Have you added the fields?

Let me know and we can troubleshoot further

Thanks,

Pramodh 

Hi @Pramodh M ,

Thanks for helping.

I only copy the description property when creating the new one in my mock project where as I try to copy the epic name in the "official" project.

But the metadata ID in the error is the same so I think it is not linked to my property copying.

Recopie screenshot.PNG

Thanks,

Sambath

Pramodh M Community Leader Aug 26, 2022

I believe some of the options such as a summary when creating issue is required.

Have you tried copying the summary field?

If you select more options above the description you will be able to select it

As I am in French langage, my "Resumé" is the Summary property

Hi @Pramodh M ,

My rule it this one :

Recopie screenshot.PNG

As you can see, for the creation, the property "Résumé" (=> Summary in english) is created by default.

But when I execute it :

journal_audit_Regle_RECOPIE.PNG

 

It does not work...maybe another property is mandatory but not created by default ? Is my target project the problem ?

 

Thanks !

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Jira Software

An update on Jira Software customer feedback – June 2022

Hello Atlassian Community! Feedback from customers like you has helped us shape and improve Jira Software. As Head of Product, Jira Software, I wanted to take this opportunity to share an update on...

5,008 views 18 31
Read article

Atlassian Community Events