Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Edit Sprint is missing despite correct permissions

Hi,

 

Since one of the last updates of Jira Software Server (it's the most current version now) the "Edit Sprint" Button is missing for me and I'm unable to Edit Sprint Names or Dates, I can just start and end them.

Has anyone of you an idea how to get it working again? I checked all permissions and they seem to be right, I have global administrator permissions anyway.

 

Greetings,

Daniel

3 answers

1 accepted

2 votes
Answer accepted

Hello @daniels7 and @wiLLow

Sorry for the delayed response and thank you for the details provided. I took some time to further investigate it, however, I was able to come up with another possible root cause:

Per your description, it seems you are able to manage Sprints (Delete, complete, etc), however, not able to edit the start/end dates.

After further investigation of other similar reports and trying to reproduce the same scenario you are facing (Configuring the German Language), I think you might be facing the following bug:

Wrong translation for Edit Sprint in German 

Can you confirm if you have the option "Sprint Beenden" under the three dots menu and check if it provides you with the display to edit the start and end dates?

Screen Shot 2020-06-22 at 13.06.12.png

If that's the case, please vote and watch the bug to increase its priority and also receive notifications about any updates.

If that's not the case, please open a new ticket with or internal support so we can further investigate your scenario:

https://support.atlassian.com/contact/ 

Let us know if this information helps.

Dear @Petter Gonçalves 

thank you very much! I can confirm, that's the wrong translation. "Sprint beenden (End Sprint)" opens the "Edit Sprint" menu.

I will vote for the bug - but your comment solved my problem as a workaround.

 

Edit-Sprint.png

Like Petter Gonçalves likes this

I'm glad that my answer have helped you, @wiLLow

Have a nice week ahead and let us know if you have any other questions.

Hello @Petter Gonçalves : Thank you very much, this is indeed the issue :-)

 

I upvoted the corresponding bug as you said.

 

Greetings,

Daniel

Like Petter Gonçalves likes this

Hello @Petter Gonçalves and @wiLLow ,

 

I'm sorry it took so long to answer, but due to COVID19 and everything I haven't had time to look deeper into this again. Sadly we still face the same problem, even with Version 8.9.0 installed now.

To answer your questions:

1. The problem we're facing is that I'm neither able to rename sprints nor can I change start and end dates. If I hover over name or dates nothing happens and the three dot menu on the top right of the sprint just allows me to end the sprint or delete it if it's a future sprint. The interface looks exactly like on the screenshot that @wiLLow posted.

 

2. The general settings look like that:

jira1.PNG

 

3. The permission helper shows this:

jira2.PNG

jira3.PNG

 

 

Additionally I ran the integrity checker and it even found a permission problem, though fixing it didn't help in any way and the problem still persists.

 

I hope you can help me.

 

Greetings,

Daniel

Hi @Petter Gonçalves ,

 

I know it took me quite a while to respond to everything you wanted to know, though it would be nice to get any kind of response now, especially since I don't seem to be the only person with that problem.

 

Greetings,

Daniel

Like wiLLow likes this
0 votes

Hello @daniels7

Thank you for reaching out. Sorry to see you are facing a problem.

 To allow the management of a specific Sprint in Jira, the user must have the Manage sprints and Schedule Issues permissions in all the projects returned by the board filter where the Sprint is located.

That being said, I believe the problem you are facing is probably caused by an update in the board filter or in your project permissions. These would be the steps to fix it:

  1. Navigate to the board where the Sprint is located > ... > Board settings > General
  2. Check what are the projects returned by your board:
    Screen Shot 2020-04-20 at 21.20.25.png
  3. Navigate to each one of the projects and add yourself with the Manage sprints and Schedule Issues permissions under Project settings > Permissions or ask a project admin to add you with those permissions, as mentioned in the documentation below:
    Managing project permissions 
  4. P.S: If you are using a complex filter in your board and Jira can not identify which projects are related to your filter, you must be added with the mentioned permission to ALL the projects in your site, or simplify the board filter.

For more details about the information above, you can check the documentation below:

Can't complete the sprint 

Let us know if you have any questions.

Hello @Petter Gonçalves ,

 

I already saw those articles which mentioned Board Filters, but that's not possible for us, since just one Project has special board filters and all others have a default filter like "project = DTT ORDER BY Rang ASC" and I can't manage Sprints anywhere anymore. The necessary permissions are set as well.

I can't understand why it happens and it was definitely working 1-2 months ago when I used it last. We adopt to new Jira and Confluence Updates very fast so I think it came through an update.

 

Greetings,

Daniel

Hello @daniels7

Thank you for your details.

Please, provide us with the following information so we can further troubleshoot the issue:

  1. What is the exact problem you are facing? would it be a greyed-out button? Are you only being blocked from edit Sprints or for starting and complete Sprints as well? Provide us with a screenshot displaying the problem itself, please.
  2. Provide us with a screenshot from the general settings of one of your boards that only contain a single project just like the one I provided you.
  3. Provide us with another screenshot from the permission helper (Under Project settings > Permissions) in the same project of the board, as the one displayed below. You should select the following details:
    - Your user
    - Any issue returned by your board filter
    - Manager Sprint and schedule Issues permissions
  • Screen Shot 2020-04-21 at 13.53.45.png

Additional to that, I suggest you try the following steps:

  1. Run the integrity checker for duplicated permissions in your instance to ensure you are not facing any incoherence there. P.S: Make sure to only check the box related to duplicated permissions and make sure to backup your data before correcting any data inconsistencies.
  2. I see some reports of other users describing that they were only able to manage Sprints with the Administer project permissions. Would it be possible to add your user with that permission and test it in one of the boards?
  3. If the buttons are greyed-out, please hover your mouse over it and check if any error messages are returned. 

Hi, we are facing the same problem after the Update 8.8.1 (from 8.7). We are using ServiceDesk and 2 Boards for the IT-Ticket Project. After the last update we cant edit Sprints (even as global administrator and project administrator) anymore.

grafik.png

@Petter Gonçalves @daniels7 

I can confirm, that the problem persists with 8.9.0

I upgraded a second jira instance yesterday from 8.7 to 8.9. After that, i couldn't rename Sprints anymore (i am the project and jira admin with full access). I think this is clearly a bug.

Same here. The inline edit button is missing. JIRA 8.11.0

Hello @Christian John

Thank you for reaching out.

Please, note that the problem mentioned in this thread was already addressed:

It is caused by a wrong translation when using the German language, where the "Edit Sprint" button was being added as "Sprint beenden" which means "Sprint end", causing confusion:

Wrong translation for Edit Sprint in German 

If you are not using Jira with German translation and this is not the problem you are facing, I suggest opening a new question with a screenshot of the problem and further details so we can properly investigate what might be causing your issue.

With no further details of your issue, we suggest navigating under Project settings > Permissions in the projects related to your board and use the Permission helper to confirm that you have the Manage Sprint and Schedule Issues permissions

Regards.

Hi all,

I know this was awhile back but it came at top of the lsiting when I search for this issue so leaving my resolve here albeit not the original issue.

I just had this same problem (Not the German issue but the losing manage/edit sprint all of a sudden) check if at the end of your JQL you have 'OR labels = WhateverName ORDER BY Rank ASC' if so remove it save then check if you have acces again, it just solved my issue.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
8.8.0
TAGS
Community showcase
Published in Marketplace Apps & Integrations

Staying organized with Jira: best practices for a better project management

Project managers know this problem: A “mountain of work” lays in front of you, and you don’t know how and where to tackle them. Different to-dos lie ahead, but just one task after the other can be ha...

248 views 2 1
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you