Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

The app host returned HTTP response code 503 when we tried to contact it during installation.

Hello!

I am trying to install the atlassian-connect-spring-boot-sample-ajax plugin from https://bitbucket.org/atlassian/atlassian-connect-spring-boot-samples/src/master/)

I have changed the base-url in my application.yaml to my ngrok-url and started the application. 

spring.jpa.hibernate.ddl-auto: update
spring.datasource.url: jdbc:hsqldb:file:addon-db # Use a file-based backing store for HSQL

addon.base-url: https://<id>.ngrok.io:${local.server.port}

logging.level.com.atlassian.connect.spring: DEBUG

 

The response of https://<id>.ngrok.io/atlassian-connect.json is:

{
  "key": "atlassian-connect-spring-boot-sample-ajax",
  "baseUrl": "https://<id>.ngrok.io:8080",
  "name": "Atlassian Connect Spring Boot AJAX Sample",
  "authentication": {
    "type": "jwt"
  },
  "lifecycle": {
    "installed": "/installed",
    "uninstalled": "/uninstalled"
  },
  "modules": {
    "generalPages": [
      {
        "key": "ajax-page",
        "location": "system.top.navigation.bar",
        "name": {
          "value": "AJAX Sample"
        },
        "url": "/iframe",
        "conditions": [
          {
            "condition": "user_is_logged_in"
          }
        ]
      }
    ]
  }
}



 

When I upload the URL in confluence cloud to install the app, then confluence response with the message: 

The app host returned HTTP response code 503 when we tried to contact it during installation. Please try again later or contact the app vendor.


 

Does anyone have any ideas how I could solve this problem?

Thanks in advance.

1 answer

1 accepted

1 vote
Answer accepted
Andy Heinzer Atlassian Team Mar 05, 2021

Hi Bernd,

Sorry to hear about this problem.  However I believe that this error happened during a time when there was a problem specifically with installing apps to Cloud sites.  Some more details are in https://jira-core.status.atlassian.com/incidents/pkb2zv9xxhn2

At the time of writing my response, this incident has been resolved.  So you should now be able to install such apps to a Cloud site again now.  If not, then perhaps there is something else wrong here, but I'm betting that this was due to the outage linked above.

Let me know if this helps.

Andy

Hello Andy,

thank you for your response.

 

Unfortunately I still have this problem with my spring boot example. 

When i run and install the node.js example from here the installation works.

But if I run and install the spring boot example i always get the response code 503. 

 

Best regards,

Bernd

Andy Heinzer Atlassian Team Mar 08, 2021

Hi Bernd,

Sorry that I misidentified the cause of your error here.

I tried to look into your problem further.  I found that are errors being thrown when the Atlassian Cloud site is trying to reach that address:

Error contacting remote application at 'https://f2d*******5b.ngrok.io:8080/installed?user_account_id=5fd*************5f' 503:[Service Unavailable]:<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html><head>
<meta type="copyright" content="Copyright (C) 1996-2017 The Squid Software Foundation and contributors">
<meta http-equiv="Content-Type" CONTENT="text/html; charset=utf-8">
<title>ERROR: The requested URL could not be retrieved</title>

I do not have a clear answer as to exactly why this is failing.  The only oddity I found here is that you appear to be using the HTTPS protocol, but using port 8080 for it.  While app installs like this can utilize either port 8080 or port 443, perhaps our Cloud site is expecting that the protocol will match the port type (such at if using 8080 you use HTTP, and if using HTTPS use port 443).  If that is not the case, then there is still something with that URL that appears to be invalid from our Cloud site.

Honestly, I am not certain if this is the cause.  I am afraid I am not as well versed in the field of app creation.  It might be helpful to reach out on our Developer Community as well https://community.developer.atlassian.com/ This site tends to be better geared towards these kinds of questions.

Andy

Like Angélica Luz likes this

Hello Andy,

your thoughts on the ports helped me to solve the problem. 

Thank you very much!

 

Bernd

Like Andy Heinzer likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Jira Service Management

Security Advisory for Jira Service Management

On October 20, 2021, Atlassian published a security advisory for Jira Service Management. The full advisory is available at this link.  We've seen a number of questions already asking for...

195 views 1 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you