Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Issues adding new users to JSD project Edited

Hi

I have added a few 'people' to my service desk project. They have been assigned the 'service desk team' role.

When I check permissions, service desk team is listed beside assignable user, assign issues, create issues, delete etc.

I assume any user with the service desk team role can perform these actions, but they cannot.  These users can't change the job status, reassign it or even close it. When trying to change the status they get the error 'you dont have permission to transition this issue'.

Some other users were added weeks ago, and they have full permission to perform these actions. I never adjusted their permissions, they were simply added to the people screen like I am currently trying to do. But that is not working now.

Am I missing something here? Or does it take a few hours for these permissions to actually apply to users?

Thanks for your help!

1 answer

1 vote
Veera Atlassian Team Jan 13, 2020

@John G

'Transition Issue' is one of the Jira Project Permissions which is required if the user wants to change the status of the ticket.

Make sure service desk team is granted 'Transition Issue' permission at the project level.

Audit logs (in Jira general settings) may give you some info if the permission scheme was changed recently which might be causing the issue.

Hi Thanks for the response,

I have found the permission scheme for my service desk project, and I can see 'Project Role (Service Desk Team)' is already next to Transition Issues. I tried removing it and adding again but still the same issue remains. Service Desk Team shows under every 'issue permissions' type. Could another permission be causing this?

I also checked and no other permission schemes are being applied to this project, and I could not see anything in the global permissions that would be causing this.

Like Veera likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Asked in Jira Service Desk

Calling all Insight users, we need your help!

Hello Insight users,  As part of our (Mindville's) acquisition by Atlassian, our training team is looking to build some new Insight training materials. It would really helpful if you can ...

49 views 0 0
View question

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you