Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JQL-Error in structure while automation

I have a Automation for Jira rule which gives me an error, if there are 2 issues found. If it's only one issue the rule works as expected.

In this rule is a JQL:

issue in structure("DEMOANF1","descendant of {{issue.key}} AND [MyCustomTime > '{{triggerissue.MyCustomTime.jqlDateTime}}']")

This JQL gives the following error message inside the automation.

JQL search failed for some issues. This is most likely because the JQL with smart-values was not valid for this query:
"(issue in structure("DEMOANF1","(descendant of DEMOANF1-252) AND ([MyCustomTime > '2020-02-04 13:54'])")) AND (project in (15001))" - Failed to validate jqlFunction 'structure', possibly plugin supplying it had thrown exception. Check the logs."

Outside the automation it works. The error message is independant if there are issues found or not.

 

1 answer

1 accepted

0 votes
Answer accepted

I have found a possible solution that works on the test system and we will try in the productive system:

If I move the JQL part of the S-JQL outside the structure function, I don't get the error anymore. So the JQL will then be

issue in structure("DEMOANF1","descendant of {{issue.key}}") AND MyCustomTime > '{{triggerissue.MyCustomTime.jqlDateTime}}'

It would be a pleasure if anyone can provide an explanation for this behavior.

Hello Erik,

The query should work the same both ways regardless of the way it's composed. But since it's executed via another app, it is possible that it might be built differently or the related error is related to something going on on the system.

We recommend to look into the following:

- When the S-JQL is executed via the Automation rule, the query itself might not be built correctly because of the used smart values. We would recommend creating a rule without such values and check how it goes.
- The other reason might be a specific problem on one of the nodes. To figure out if it's the culprit or not, you can run the first query(with the error) on each node and see if it provides the same results or not.

You can also contact us at support.almworks.com if you need further assistance. We'll be glad to check the logs and investigate this problem deeper if needed.

Best regards,
Stepan Kholodov
ALM Works

Like Erik Buchholz likes this

Hi Stepan,

thanks for your reply.

1. When I replaced the smart values and validated the query in the rule: 1 issue found, but when I run the rule I get the same error as before.

2. When I run the query on the different nodes I always get the expected result.

So I think the problem is the execution via Automation 4 Jira.

Best regards,
Erik

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Core

How to manage many similar workflows?

I have multiple projects that use variations of the same base workflow. The variations depend on the requirements of the project or issue type. The variations mostly come in the form of new statuses ...

3,953 views 11 5
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you