Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Jira Align 10.123 On-Premise driver requirement

As announced on August 3rd, Jira Align On-Premise version 10.123 (or above) requires a new OLE DB to function.

What's changing?

Jira Align used the SQL Server Native Client (SNAC) driver from releases 10.x until 10.122. Microsoft recommends switching SNAC to the Microsoft OLE DB Driver (MSOLEDBSQL) for SQL Server going forward.

Impacted deployments

On-Premises only. Jira Align SaaS customers are not impacted by these changes. 

Action required

Before installing Jira Align version 10.123, ensure that all web and connector servers in your environment are updated with the OLE DB driver, version 18 or above.

On-Premise customers are recommended to read the full announcement here.

Frequently Asked Questions

What's SNAC?

SNAC is the abbreviated form of SQL Server Native Client. It’s sunsetting by Microsoft.
It was the database driver originally used in Jira Align, up to the 10.122 release.

What’s OLE DB driver?

The OLE DB driver is Microsoft’s recommended replacement for SNAC. It will be the database driver used by Jira Align, effective from the 10.123 release.

Can both drivers coexist at the same time?

Yes, both drivers can coexist at the same time. Having the OLE DB driver installed along with the old SNAC driver, does no harm to Jira Align. They’re independent of each other.

What OLE DB version is required?

The required OLE DB driver version is 18 or above.

Where to download the OLE DB driver?

The OLE DB driver can be downloaded from this pageAlternatively, it can be downloaded directly from this link.

Does the OLE DB driver installation require a system reboot or a DB server reload?

The OLE DB driver installation can be done with Jira Align up and running. It does not require a system reboot or an application restart.

I’m running Jira Align 10.122 (or earlier) and have NO plans to upgrade to 10.123 (or later). Do I have to install the OLE DB driver?

Jira Align – up to 10.122 – makes no use of the OLE DB driver. The OLE DB driver is only required by the Jira Align 10.123 release onwards. If you have no plans to upgrade to the 10.123 (or later) release now, then you don't have to install the OLE DB driver. You’re gonna be fine with SNAC only.

I’m running Jira Align 10.122 (or earlier) and planning to upgrade to 10.123 (or later). Do I have to install the OLE DB driver?

Yes. The OLE DB driver is required by the Jira Align 10.123 release onwards. If you have plans to upgrade to the 10.123 (or later) release now, then you must install the OLE DB driver.

What are the high-level upgrade steps to Jira Align 10.123?

For supported versions, find below the overall upgrade steps for an existing Jira Align deployment:

  1. Download the new OLE DB driver

  2. Install the new OLE DB driver on all Web and Connector servers

  3. Download the Jira Align 10.123 installation package

  4. Upgrade Jira Align as usual

The OLE DB driver upgrade is transparent to the application and does not require any additional configuration changes.

DO NOT attempt to upgrade to the 10.123 release without installing the OLE DB driver. That will prevent the application from running.

I’m running an outdated version of Jira Align. What should I do?

The general guidance is:

  • Customers running from the 10.x release up to the 10.109, must upgrade to 10.117 prior to any subsequent release
  • Customers running from the 10.110 release up to the 10.122, can upgrade to the 10.123 release

Check each release’s upgrade note for specific requirements & corresponding instructions.

Are there any changes to the web.config configuration file?

No. The OLE DB driver does not require any changes to any configuration file.

Are there any changes to the connection string ?

No. The OLE DB driver does not require any changes to the connection string.

The OLE DB driver is installed now. What should I do with SNAC?

The SNAC driver is still required for Jira Align 10.123.2 to function.

If you're upgrading to Jira Align 10.124 (or above), you can remove the SNAC driver from your system as that dependency has been removed.

Still have questions?

Don’t hesitate to reach out to the Jira Align Support team should you have any concerns.

0 comments

Comment

Log in or Sign up to comment
TAGS
AUG Leaders

Atlassian Community Events