Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Some merge changesets showing 0 files changed

Using bitbucket git and crucible.  All changes are made on feature branches.  Those branches are then merged to an integration branch, which is merged back to master.

When I try to create a review in Crucible, I do one of two ways: Select all the changesets in the feature branch OR select just the changeset where the feature branch is merged into the integration branch.

These have worked fine for over a hundred reviews of several hundred branches.  Recently I came across an issue where the merge of the feature branch to integration branch in crucible shows 0 files changed so I cannot set up a review.  Looking in git, I can see the changeset has files changed.  The changeset isn't missing completely because it shows the start of the sha-256 in crucible as usual.  It just does not have the actual changes.  I see this on several branches, not all consecutive, with no discernible pattern.

We tried stopping/restarting crucible to make sure it is in sync.

Any ideas?

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

⏰ Day in the life of a Jira Admin!

Hello Community! We thoroughly enjoyed this just-for-fun conversation in the Jira Admin Group about what it's like to be a Jira Admin. For #JiraJuly, our talented designers created these graphics t...

594 views 2 18
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you