Setting up FishEye in EC2

I am in the process of migrating off of OnDemand FishEye and onto EC2 using the Atlassian AMI (running Ubuntu).

I have backed-up up my FishEye and Crucible data and copied to my new EC2 instance, but when trying to import the data using command:

./ restore -f /sw/

I get the following:

INFO  - Using log4j configuration file: /sw/fecru-2.9.1/log4j-client.xml
INFO  - FishEye arguments: [-f, /sw/]
Starting Spring Context...
config.xml not found in archive. config.xml not found in archive.
	at com.cenqua.fisheye.ctl.RestoreConfig.getConfigFromBackup(
	at com.cenqua.fisheye.ctl.Restore.main(
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(
	at java.lang.reflect.Method.invoke(
	at com.cenqua.fisheye.FishEyeCtl.mainImpl(
	at com.cenqua.fisheye.FishEyeCtl.main(
Restore failed - no config.xml was found in the file backup file specified /sw/

The config.xml file is located in the backup zip file, so I am puzzled as to the cause of this issue...

3 answers

1 accepted

1 vote

Which version of FishEye are you restoring backup to? Older versions of FishEye couldn't cope with folders entries inside zip file, but since 2.10 release I think those should work fine.

If that's the issue you can either try using newer FishEye or try avoiding repackaging the whole backup file. Just update the config.xml file required and update zip with this file only, using following commands:

# extract single config.xml file from a backup
unzip config/config.xml
# edit config.xml with your preferred editor now, make necessary changes
vim config/config.xml
# update with amended config.xml
zip -u config/config.xml

you may want to make a backup of your backup file first :D

Repackaging the single file worked but I got a lot of import errors. I upgraded the version of Fisheye to 3.1.3 and that took care of the import issues. Thanks Piotr!


Glad to hear the advice given worked.

Just to get you right, what exactly import errors did you have and how did you fix them? Was it sufficient to update path to the svn binary or was any more work required?


Prior to upgrading to Fisheye version 3x the import would never complete and I would receive messages like this:

INFO: command not found

foo@system:/sw/fecru-2.9.1/bin$ INFO  - Application context succesfully cl

INFO: command not found

foo@system:/sw/fecru-2.9.1/bin$ INFO  - Unpublish

INFO: command not found

foo@system:/sw/fecru-2.9.1/bin$ INFO  - Closing

INFO: command not found

foo@system:/sw/fecru-2.9.1/bin$ INFO  - Destroying singletons in or

INFO: command not found

foo@system:/sw/fecru-2.9.1/bin$ INFO  - Cancelling Timer

INFO: command not found

foo@system:sw/fecru-2.9.1/bin$ INFO  - *** appli

INFO: command not found

foo@system:/sw/fecru-2.9.1/bin$ INFO  - Destroying singletons in org.springframework.beans.factory

INFO: command not found


Upgrading the version of fisheye resolved all these messages and I was able to import successfully. I also had another issue where the user running fisheye did not have sufficient rights to the postgres database. Once this was taken care of Fisheye ran without issue.

0 vote
Nick Pellow Atlassian Team Oct 03, 2013

Can you please confirm that the config.xml is located in a directory called: config inside the zip.

e.g. config/config.xml .

Also, do you get the same error when trying to run the restore locally, away from EC2 ?

And just an FYI: the config/config.xml element is the first element read from the zip. Since this is failing it is likely that the you've provided is invalid or not complete.

Yes, there is a file inside the zip named config/config.xml and I've validated that the XML is well formed.

After some testing I've found that taking the backup directly from the backup manager and running restore works and I do not receive the "config.xml not found in archive" error.

Previously I had been extracting the zip file on my local machine and modifying config.xml to point to my new svn location, per the instructions:

It appears that its just the extracting and zipping of the backup file before running the restore that causes this issue. I've tested the zip process on both mac and windows without editing any files from the backup and it fails every time when running the restore.

My concern now is that the config.xml file that I am restoring is pointed to the wrong path for svn on my EC2 instance.

Suggest an answer

Log in or Join to answer
Community showcase
Alexey Matveev
Published Saturday in Jira

How to run Jira in a docker container

Everything below is tested on Ubuntu 17.10. I prefer to use Jira in a docker container because: 1. I can install Jira with a couple of commands. 2. I can start and stop Jira just by starting and s...

488 views 6 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot