Mercurial connection with Fisheye is breaking with error: com.cenqua.fisheye.rep.RepositoryClientExc

Mercurial version:. 4.1.2 x64(tortoise hg) downloaded from https://www.mercurial-scm.org/downloads 

python version: 2.6

fisheye and crucible version: 3.7.0

Os: windows 10

solutions tried:

1) creating mercurial.ini

2) modifying the hgfelog.py file inside the FishEye installation directory

Kindly suggest the solution

 

 

error:

Repository index failed due to error com.cenqua.fisheye.rep.RepositoryClientException: com.atlassian.fisheye.dvcs.handler.DvcsProcessException: Error while communicating with VCS: ** Unknown exception encountered with possibly-broken third-party extension felog ** which supports versions unknown of Mercurial. ** Please disable felog and try your action again. ** If that fixes the bug please report it to the extension author. ** Python 2.7.10 (default, May 23 2015, 09:44:00) [MSC v.1500 64 bit (AMD64)] ** Mercurial Distributed SCM (version 4.1.2) ** Extensions loaded: felog Traceback (most recent call last): File "hg", line 49, in <module> File "mercurial\dispatch.pyo", line 63, in run File "mercurial\dispatch.pyo", line 129, in dispatch File "mercurial\dispatch.pyo", line 219, in _runcatch File "mercurial\dispatch.pyo", line 227, in callcatch File "mercurial\scmutil.pyo", line 152, in callcatch File "mercurial\dispatch.pyo", line 208, in _runcatchfunc File "mercurial\dispatch.pyo", line 761, in _dispatch AttributeError: 'function' object has no attribute 'norepo' com.atlassian.fisheye.dvcs.handler.DvcsProcessException: Error while communicating with VCS: ** Unknown exception encountered with possibly-broken third-party extension felog ** which supports versions unknown of Mercurial.

1 answer

1 accepted

Accepted Answer
0 votes

Hi, FishEye 3.7 doesn't support Mercurial 4.1. However, 4.4 does. You need to update your FishEye&Crucible instance in order to get support for Mercurial 4.1.

Thank you Grzegorz for the instant reply. Could you please help me which version of Mercurial will be supported by Fisheye 3.7? Because I have to test onFisheye 3.7 only.

Take a look at the first link. There is a full list of supported versions but generally:

* 3.0 - 3.2

* 2.0 - 2.9

* 1.5 - 1.9

thank you very much! :)

Suggest an answer

Log in or Sign up to answer
Community showcase
Published 6 hours ago in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

48 views 0 1
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you