Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

JIRA forgets login information

When I log in to JIRA and click on Administration I am presented with a log in screen requiring username and password instead of taken to the Administration main tab. After entering my username and password again than for Administrative Access I have to enter my password again and finally the Administration main page is opened.

If I click on Create Issue I receive the error that I am not authorized to perform the operation because I am not logged on; however, even if I enter my credentials again I receive the same error and cannot create an issue.

It doesn't matter what browser I'm using Safari, IE, Firefox. None of these browsers are blocking cookies or popup windows.

Within the JIRA application log I see several lines of the scanning users but it doesn't seem to have any errors with that. Also I saw an error with the JIRA Workflow Extensions but when I Manage the Plugins in JIRA all of the JIRA Workflow Extension modules are enabled and I don't see any problem with that plugin. I do see that 5 of 14 modules of the Application Links Link Rendering Plugin are disabled but they are related to Crucible, FishEye, and Bamboo and we don't have any of those types of external applications linked. The JIRA Toolkit Plugin has the Resolved module disabled but there is also a message: DON'T use this plugin, JIRA 4.x has much more efficient system field.

Attached is the JIRA application log and the error message received when clicking Create Issue.

Thank you so much for your support that I have received on previous issues.

2 answers

1 accepted

It seemed to fix JIRA okay but I cannot log in to Confluence.

This is from Confluence's application log:
2012-11-28 17:38:20,209 ERROR [http-8090-6] [crowd.manager.application.ApplicationServiceGeneric] authenticateUser Directory 'Remote JIRA Directory' is not functional during authentication of 'cgrable'. Skipped.
2012-11-28 17:38:20,209 WARN [http-8090-6] [atlassian.confluence.user.ConfluenceAuthenticator] authenticate OperationFailedException caught while authenticating user <cgrable>.
com.atlassian.crowd.exception.runtime.OperationFailedException: The following URL does not specify a valid Crowd User Management REST service:

Here is the corresponding entry from the JIRA application log:
2012-11-28 17:32:29,163 StreamsCompletionService::thread-12 WARN anonymous com.atlassian.streams.internal.ActivityProviderConnectionMonitorImpl:activityProviderMonitor [atlassian.streams.internal.AppLinksActivityProvider] Unable to retrieve filter options from /rest/activity-stream/1.0/config?local=true

The JIRA link renderer module of the Application Links Link Rendering Plugin is disabled and cannot be enabled. Is this a problem?

What's wrong with Confluence? If I can't get into Confluence to resync the user directory, how can it be corrected?


I removed Confluence from the server.xml file but upon start-up and attempted login I receive the same error from Confluence.

It seems you are using a Remote JIRA Directory to authenticate the users. Simply changing the URL on Confluence's database to point to the new URL should do the trick. :)

Making the database change did the trick. Thank you so very much for your assitance.

I'm trying this to fix Confluence and when I stop confluence, change the crowd.server.url value in cwd_directory_attribute to the correct location for JIRA, then restart Confluence it doesn't fix things. Is this the correct value to change? Is there something else that needs to be done to force Confluence to update the URL it uses for crowd requests?

0 votes

Hi Colleen,

This problem is most often caused by the cookie being overwritten when accessing JIRA, Confluence or potentially any other applications with a web-login on the same domain or IP, such as with the below configuration:

As the cookies are not distinguished by the port number, the browser will overwrite the previous cookie and it will appear as if the user has been logged out of the previous application. As a workaround, you could use separate browsers when accessing each application (IE, Firefox, Chrome, etc) or use private browsing mode in one tab to access JIRA and normal browsing to access Confluence. This is not a recommended fix, however can be used for testing environments.


As JIRA and Confluence can be resource intensive and as part of standard best-practices, Atlassian recommends running Confluence and JIRA on separate physical machines, behind a reverse-proxy such as Apache Web Server or IIS. Please refer to Installing Confluence and JIRA Together for further information on this.

If there is a requirement to use the same machine, any of the below can be utilised to resolve this problem:

  1. Have separate DNS entries for the same IP, allowing the browser to distinguish between the two, for example:
  2. Modify the Context path in server.xml for both JIRA and Confluence as in the below example.
  3. Host both applications behind a reverse-proxy, as in Integrating JIRA with Apache & Running Confluence behind Apache.
  4. Set up Single-Sign-On with Atlassian Crowd, as in our Overview of SSO docs.
    <sup>Reference:</sup> <sup></sup>
I hope this helps!
Matheus Fernandes

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events