Installation under Mac OS 10.8

Has anybody sucessfully installed Fish Eye / Crucible under Mac OS 10.8?

I'm unable to set the JAVA_HOME variable, it always comes back as Undefined Variable in response to the echo $JAVA_HOME command.

There's no .profile file in ~/ in Mac OS 10.8. I created one and added the lines as stated in the installation instructions but the JAVA_HOME variable remains undefined.




2 answers

1 accepted

I almost daily install FishEye/Crucible test instances on my MBP running OSX 10.7.4.
For me they all run fine without having JAVA_HOME set.

If you still do want to define a JAVA_HOME you can indeed add it to ~/.profile, but the change won't take effect until you either login again, or run "source ~/.profile".

Thanks Rene - I'll give it a shot :)

I got a little bit further...

Once I've run and gone to my wen browser I always get the 'Can't conenct to server' error in Safari. On running the following appears:

FishEye not running? Problem connecting to : Connection refused Connection refused

at Method)









at com.cenqua.fisheye.ctl.BaseRemoteCommand.sendCommand(

at com.cenqua.fisheye.ctl.BaseRemoteCommand.mainImpl(

at com.cenqua.fisheye.ctl.Stop.main(

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(

at sun.reflect.DelegatingMethodAccessorImpl.invoke(

at java.lang.reflect.Method.invoke(

at com.cenqua.fisheye.FishEyeCtl.mainImpl(

at com.cenqua.fisheye.FishEyeCtl.main(

Firewall is off so it can't be that. Any idea what I'm doing wrong?



Try starting with "./" instead.
This will start FishEye in the terminal window, so you can see what it logs.
Wait for a message like this is displayed:

Server started on :8060 (http) (control port on

and then point your browser to (or another port, as it looks like you changed the configuration).
To stop a FishEye that's started with you just use Control-C.

That did the trick, thank you. I was able to see that the path to the config file wasn't found. Fixed that :) I dont' suppose you've ever connected Crucible to any of the GIT repositories on

It should be fairly straightforward to connect Crucible to an Assembla Git repository. You will need to generate a key pair for ssh and upload the public key to assembla.

I just tried it and I only had to change the label generated by Crucible to make it shorter due to the limitation for the key on Assembla. The screenshot below shows where the magic happens;

Thanks for the help :)

Still not connecting :( When I run Test Connection it fails with the following:

Thanks for your help, I really appreciate it, I'm pretty much a newbie when it comes to this stuff. Key upload seemed to be ok, I truncated the key as you advised and Assembla accepted it but when I run Test Connection I get the follwing:

Fisheye is using '/usr/bin/ssh' to authenticate with SSH authenticated repositories.

Error testing connection.
Error talking to repository:

at com.atlassian.fisheye.git.GitScmConfig.testConnection(
at com.cenqua.fisheye.RepositoryConfig.testConnection(
at com.atlassian.fisheye.spi.admin.impl.DefaultRepositoryAdminService.testConnectionFor(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(

Connection failed.

0 vote

I just ran into the same problem on OS 10.8, with Java not being installed. Actually I had run 'atlas-package', and it couldn't find my java. After putzing around trying to find the java bin, I ran java -version and that prompted a download of the JDK.

I guess Apple's trying to outsmart itself - basically, just go to a command line and enter the command 'java' to start a download of the JDK.

Suggest an answer

Log in or Join to answer
Community showcase
Alexey Matveev
Published Saturday in Jira

How to run Jira in a docker container

Everything below is tested on Ubuntu 17.10. I prefer to use Jira in a docker container because: 1. I can install Jira with a couple of commands. 2. I can start and stop Jira just by starting and s...

500 views 6 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot