How do you get Fisheye to only listen on 1 IP address

I have fisheye/crucible on a windows server that has an IIS web site already on it (an OSQA one like this)

I have got IIS to only listen to 1 IP address.

But Fisheye seems to be stealing the http requests so any request to that server end up at crucible/fisheye.

5 answers

This widget could not be displayed.

I don’t see how that is possible if they are running on the same machine?

They need to bind on a port and if it’s already used up by another service or application it will fail to start up.

If they are bound to different port then its a redirection issue on IIS

If there is a redirection setup on IIS check there to see if you can differentiate and redirect based on context or URL/virtualhost settings

This widget could not be displayed.
There are 2 IPs on the server. I should be able to assign one to IIS and one to Fisheye.
This widget could not be displayed.

According to Configuring the FishEye Web Server:

Setting HTTP Bind: The hostname the FishEye web server will bind to. This can take the form of a host name and port number, or you can leave the host name blank. If no host name is specified, then FishEye will bind to all available interfaces.

So instead of using ":8060" try "ip.add.dr.ess:8060".
Haven't tried this myself...

This widget could not be displayed.

Try

<web-server context="fisheye">
<http bind="127.0.0.1:8060"/>
</web-server>

Think you can specifiy this on the UI as well and specify proxy settings

I've set IIS to listen to 10.0.0.1 port 80 and I've set fisheye/crucible to 10.0.0.2:80 in the bind section of the config.

But when I go to crucible.x.com I go to the crucible site. And when I go to answers.x.com I also go to the crucible site. DNS is correct.

I've tried setting the bind entry to the ip address and the dns name for crucible and its still not working :(

This widget could not be displayed.

I've set IIS to listen to 10.0.0.1 port 80 and I've set fisheye/crucible to 10.0.0.2:80 in the bind section of the config.

But when I go to crucible.x.com I go to the crucible site. And when I go to answers.x.com I also go to the crucible site. DNS is correct.

I've tried setting the bind entry to the ip address and the dns name for crucible and its still not working :(

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

216 views 3 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you