It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Fisheye proxy settings on Windows. JIRA looks good, Fisheye is jumbled.

 

We have installed JIRA and Fisheye on a remote server running Windows Server 2008 r2. Both Jira 7.10.0 and Fisheye 4.5.3 are installed as Windows services. While remote desktop connected to the server we can browse to localhost:8080 for Jira and localhost:8060 for Fisheye. Both work properly. We've setup DNS entries to access the sites via jira.cantatahealth.com and fisheye.cantatahealth.com.


Traffic comes in on 443 and is translated to 4343 to the load balancer (jetNEXUS) where we have SSL offload and then layer 7 route to the destination app server on port 8080 (Jira) or 8060 (Fisheye). We're using Windows 2008R2\IIS7.5 for Fisheye and the jetNEXUS are self-contained CentOS-based appliances.

Accessing jira.cantatahealth.com works correctly.


Accessing fisheye.cantatahealth.com loads but the pages are broken. This happens with all browsers. Using development tools to view network traffic all resources load with status 200. Using development tools to view page source for Fisheye I see 5 nested doctype statements. For example:


!doctype
<head>
code... no end of head tag
!doctype
<head>
code ..... etc.


In server.xml for Jira we have this section:


<Connector port="8080" maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false"

maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443"

acceptCount="100" disableUploadTimeout="true" bindOnInit="false" secure="true" scheme="https"

proxyName="jira.cantatahealth.com" proxyPort="443"/>


For Fisheye we've tried several combinations of proxy settings including:
http bind = :8060
Proxy Scheme = not set
Proxy Host = not set
Proxy port = not set
Site URL = https://fisheye.cantatahealth.com

And

http bind = :8060
Proxy Scheme = https
Proxy Host = fisheye.cantatahealth.com
Proxy port = 443
Site URL = https://fisheye.cantatahealth.com


We've also tried JVM input arguments:


JVM input arguments -Dfisheye.library.path= -Dfisheye.inst=C:\Atlassian\Data\fecru -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djava.endorsed.dirs=C:\Atlassian\fecru-4.5.3\lib\endorsed -Xmx1024m

And


JVM input arguments -Dfisheye.library.path= -Dfisheye.inst=C:\Atlassian\Data\fecru -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djava.endorsed.dirs=C:\Atlassian\fecru-4.5.3\lib\endorsed -Xmx1024m -Dhttp.proxyHost=fisheye.cantatahealth.com -Dhttp.proxyPort=8060 -Dhttps.proxyHost=fisheye.cantatahealth.com -Dhttps.proxyPort=8060 -Dhttp.nonProxyHosts=localhost

We're not able to get Fisheye to load properly via remote URL.

What are we missing?

 

 

0 answers

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Posted Wednesday in Jira

Upcoming Enterprise releases targeting Q3 2019: Jira Software 8.5 & Jira Service Desk 4.5

Since launching the Jira Software 8.0 and Jira Service Desk 4.0 platform releases in February, many of you have been asking when the next Enterprise release will be so you can take advantage of the m...

337 views 3 8
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you