Fisheye Managed Git Repo indexing failed

Hello! I`m using FishEye 2.8.2.

My SVN repo works great, it`s indexing and scanning well.

But now I have to create managed git repo. Connected via ssh, auth by keypair, different port and gitolite on another side.

Connecting to repository succeeded. Only one problem, fisheye cannot index it, and give me the error like this:

Repository index failed due to error org.hibernate.exception.GenericJDBCException: Cannot open connection java.sql.SQLException: com.mchange.v2.c3p0.PoolBackedDataSource@eb06e1c4 [ connectionPoolDataSource -> com.mchange.v2.c3p0.WrapperConnectionPoolDataSource@3d0e1f43 [ acquireIncrement -> 3, acquireRetryAttempts -> 30, acquireRetryDelay -> 1000, autoCommitOnClose -> false, automaticTestTable -> null, breakAfterAcquireFailure -> false, checkoutTimeout -> 0, connectionCustomizerClassName -> null, connectionTesterClassName -> com.mchange.v2.c3p0.impl.DefaultConnectionTester, debugUnreturnedConnectionStackTraces -> false, factoryClassLocation -> null, forceIgnoreUnresolvedTransactions -> false, identityToken -> 1hgep3b8qtbn0bw42ubx1|1e1116f9, idleConnectionTestPeriod -> 0, initialPoolSize -> 5, maxAdministrativeTaskTime -> 0, maxConnectionAge -> 0, maxIdleTime -> 1800, maxIdleTimeExcessConnections -> 0, maxPoolSize -> 20, maxStatements -> 50, maxStatementsPerConnection -> 0, minPoolSize -> 5, nestedDataSource -> com.mchange.v2.c3p0.DriverManagerDataSource@bd221537 [ description -> null, driverClass -> null, factoryClassLocation -> null, identityToken -> 1hgep3b8qtbn0bw42ubx1|ad9edbe, jdbcUrl -> jdbc:hsqldb:file:/var/www/fisheye/var/data/crudb/crucible, properties -> {user=******, password=******, autocommit=false} ], preferredTestQuery -> null, propertyCycle -> 0, testConnectionOnCheckin -> false, testConnectionOnCheckout -> false, unreturnedConnectionTimeout -> 0, usesTraditionalReflectiveProxies -> false; userOverrides: {} ], dataSourceName -> null, factoryClassLocation -> null, identityToken -> 1hgep3b8qtbn0bw42ubx1|45490852, numHelperThreads -> 3 ] has been closed() -- you can no longer use it.

When I worked on hsdb and test fisheye this repo worked normal, nut now when I`m on MySQL a have this problem.

Collation and charset in database right, and I have no idea what to do.

1 answer

0 vote

The best bet would be to turn on debug logging, capture the problem with the repository and then create a support case at support.atlassian.com

My suspicion is that this is not related to the the SQL database, but we would need more info to be sure.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Marketplace Apps

Tips on how to choose the best estimation method for your planning

Planning and grooming sessions all come with their own sets of rules. Team members meet to estimate stories or other work items, all according to an agreed-upon process. And with every session comes ...

78 views 0 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you