Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,405
Community Members
 
Community Events
176
Community Groups

Crucible Indexing is very slow and Stuck

I have initiated the indexing of data and its very slow and stuck at svn diff command.

I know the revisions and branches i want to avoid and should not be considered for indexing therefore i have exclusions in place. Its seem below command is standard procedure Crucible is following to grab the changes or difference.

svn diff --summarize -r 90907:90908 file:///D:/SubversionMirrors/Repos/Directory@90908

These particular revision and some other include more than million transaction or changes and taking very long time because of which indexing has not completed yet and review requests don't have proper data.

I tried below option to resolve this:

  1. Configured exclusions
  2. Configured Symbolic rules
  3. Increased subversion timeout period to 1 day
  4. Tried fixing resource utilization to 1 and 3

Can anyone suggest me any option which can avoid svn diff command on the revision having million changes?

OR

How can i make my indexing faster and other issue i am in right now is indexing never completes but always show 99.9% completed. 

Can anyone please help?

 

2 answers

1 accepted

0 votes
Answer accepted

Hi Taha,

I used "time ./jsvn diff --summarize" feature in FISHEYE_INSTANCE/lib/svn/jsvn to know the time it would take to complete the command. As per result it should have finished the process in 1hr and 3 minutes but to my surprise it is not.

I know the similar revision which have milion changes and will take time not sure how much. I want to avoid those revision as the operation performed on those revisions was svn move to archive outdated old branches.

If there is anyway to avoid this command on those revision that would help to resolve the problem. 

Thanks for suggestion

 Regards,

  Balbir

 

You can tell Fisheye to Start Indexing from a particular revision but unfortunately you can't tell it to skip a particular revision. There is feature request with atlassian for this - https://jira.atlassian.com/browse/FE-626 I agree if we have feature to skip revision then it would be very handy in these case. We also faced this kind of issue in the past but only way to get around is to increase the time out and wait for these revision to complete. What Atlassian suggested to improve performance is to use *Native Subversion Client* but haven't tried since it may increase memory usage during reindexing. You can check this document for more info https://confluence.atlassian.com/fisheye/native-subversion-client-298976879.html

Thanks i think you are right wait is good way to move ahead.

1 vote

Hi Balbir,

Firstly try to run this command on you Subversion Server itself and note down the timing

svn diff --summarize -r 90907:90908 file:///D:/SubversionMirrors/Repos/Directory@90908

Then try to increase subversion timeout, it can be more than 1 day as well.

Taha

 

 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events