Connecting Fisheye to a remote Repository Location


I am trying to connect fisheye to a Mercurial remote repository, and get the error :

Unable to pull from remote repository: <DIRECTORY> - [abort: repository <DIRECTORY> not found!]

From the same PC, I can clone the remote repository (using tortoise with the same options) and once on a local directory, I can connect it with fisheye.

I have the correct right on the remote directory, the same Mercurial revision.

Any idea ?


2 answers

1 accepted

0 vote
Nick Pellow Atlassian Team Jun 10, 2014

Some ideas to consider/check and in no particular order:

  • does the fisheye runuser have correct access to clone/read from the repo?
  • have you tried running the same command exactly that fisheye is trying to run when cloning the repo
  • what have you put in place of the URL field in the FishEye configuration screen? Does this exist?
  • for the remote repo - is it protected by password or ssh ? If so, are all your credentials in place ? ie. you've generated a key/pair in fisheye and uploaded the public key to your mercurial server ?
  • what does the Test Connection reveal in FishEye

Updated to the latest version of Fisheye.

Issue came from the service Wrapper not using the configured user.

It now works.



- The run user has the read right on the directory. Is tried with the service user set to my user also, without any success.
- The same command "C:\Mercurial\hg.exe --config ui.verbose=false clone --noupdate -r 0 \\fav19win\SRS\srs D:\FISHEYE_INST\var\tmp\hg_test_clone_1402469900574" run from the Windows console create the cloned version
- The URL field is set to \\fav19win\SRS\srs and this exists.
- There is no SSH authentification, the remote directory is read only.
- the test connection returns :

Error testing connection.
Non-zero exit code: 255
at com.atlassian.utils.process.PluggableProcessHandler.complete(
at com.atlassian.utils.process.ExternalProcessImpl.wrapUpProcess(
at com.atlassian.utils.process.ExternalProcessImpl.finish(
at com.atlassian.utils.process.ExternalProcessImpl.execute(
at com.atlassian.fisheye.dvcs.DvcsScmConfig.executeCommand(

Connection failed.

Suggest an answer

Log in or Join to answer
Community showcase
Bridget Sauer
Published Mar 09, 2018 in Jira Service Desk

E.L. Fridge's take on education, Jira Service Desk, and creative Jira use cases

...word of mouth, so by 2016, we were working with several other entities on campus to implement Jira Service Desk . The Atlassian motto of “for every team” has really come true for us in this case. We...

335 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot