Locked out of crowd

I installed jira and confluence. I had only one account in each which used the same username but different password. All worked fine. I then installed crowd and the one user had the same username. So all three same username different passwords. I tried to connect up crowd to jira. I imported the account from jira and now crowd won't let me log in to crowd. I have even utilized the reset password functionality. When I log in it just brings me right back to the login screen without any complaints.

I'll tell you, installing jira and confluence went smoothly. Having to set up crowd after those two installs is a nightmare. It really should be easier to set up crowd with jira and confluence.

Anyway, any help getting back in to crowd so i can troubleshoot why my SSO isn't working, would be appeciated.

[updated] I rebooted and now I have all three running but I cannot log in to crowd or jira. Where can I find any error logs that might assist me?

[update] I am convinced that I am actually "logging in" properly, but that it is bringing me straight back to the login page. Because I get an invalid login error if I use the wrong username or password, but no error when I use the correct one. So what would cause me to go back to the login page after successfully logging in?

[update] A buddy suggested I try a different browser. Why not? It worked! so it looks like this might have to do with cookies, but even after deleting/resetting the problem browser (safari) I am getting the looping behavior. Chrome seems to work fine.

4 answers

1 accepted

I had this issue and it was resolved by clearing cookies & cache - old post but the problem still persists and there is nothing in the documentation to recommend clearing your cookies.

I was able to things fixed. It was because there were two users with the same name. I went into the actual database and changed the login name for one of the account and then was able to delete that user. Once i was down to just one user with that name. Things appear to be working properly.

Still doesn't work with Safari. Has to be a cookie issue. (Or associated setting).

WOW. Moved from work to home and all I can login to is crowd. This isn't good. Why is this so difficult to set up?!?!

I gave up. Deleted everything. I'll try again some other day.

0 votes
Colin Goudie Community Champion Nov 03, 2011

Sounds like it is a browser cookie issue. Clear *ALL* your history and retry when at work, you'll probably find it works.

Can't recall if safari has a nice way to view/clear cookies (I guess) but it's the crowd token you want to get rid of and retest

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Thursday in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

282 views 0 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot