Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,881
Community Members
 
Community Events
176
Community Groups

Crowd upgrade from 2.2.4 to 2.4.0 fails. Bootstrap Error: Not enabled: Crowd REST API

I am performing an upgrade on Crowd to the latest version according to the steps described on http://confluence.atlassian.com/display/CROWD/Upgrading+Crowd+via+Automatic+Database+Upgrade

But when I start the new installation, it fails and shows me the error page:

2012-02-10 17:20:14 fatal Required plugins failed to initialise. Please check the logs for errors and restart Crowd. Not enabled: Crowd REST API

Please help me, i want to get this up and running so my developers can continue with their jobs :)

Logfile excerpt:

2012-02-10 15:56:17,556 FelixDispatchQueue INFO [osgi.container.felix.FelixOsgiContainerManager] Resolved bundle com.atlassian.auiplugin (10)

2012-02-10 15:56:17,569 FelixDispatchQueue INFO [osgi.container.felix.FelixOsgiContainerManager] Started bundle com.atlassian.auiplugin (10)

2012-02-10 15:56:17,585 main ERROR [plugin.osgi.factory.OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.crowd.crowd-sync-feedback' : Unresolved constraint in bundle com.atlassian.crowd.sync-feedback [11]: Unable to resolve 11.0: missing requirement [11.0] package; (&(package=com.atlassian.plugins.rest.common.security.jersey)(version>=2.5.0)) [caused by: Unable to resolve 13.0: missing requirement [13.0] package; (package=javax.xml.bind)]. This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D

2012-02-10 15:56:17,588 main WARN [plugin.osgi.factory.OsgiPlugin] Unable to enable plugin 'com.atlassian.crowd.crowd-sync-feedback'

com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.crowd.crowd-sync-feedback

at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430)

at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237)

at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213)

at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114)

at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99)

at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682)

at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156)

at com.atlassian.crowd.plugin.CrowdPluginManager.init(CrowdPluginManager.java:67)

at com.atlassian.crowd.plugin.CrowdPluginManager.onApplicationStartedEvent(CrowdPluginManager.java:80)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:601)

at com.atlassian.event.internal.SingleParameterMethodListenerInvoker.invoke(SingleParameterMethodListenerInvoker.java:36)

at com.atlassian.event.internal.AsynchronousAbleEventDispatcher$2.run(AsynchronousAbleEventDispatcher.java:60)

at com.atlassian.event.internal.AsynchronousAbleEventDispatcher$1.execute(AsynchronousAbleEventDispatcher.java:28)

at com.atlassian.event.internal.AsynchronousAbleEventDispatcher.dispatch(AsynchronousAbleEventDispatcher.java:56)

at com.atlassian.event.internal.EventPublisherImpl.invokeListeners(EventPublisherImpl.java:151)

at com.atlassian.event.internal.EventPublisherImpl.publish(EventPublisherImpl.java:70)

at com.atlassian.crowd.console.listener.StartupListener.contextInitialized(StartupListener.java:104)

at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4205)

at org.apache.catalina.core.StandardContext.start(StandardContext.java:4704)

at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:799)

at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:779)

at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:601)

at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:675)

at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:601)

at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:502)

at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1315)

at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:324)

at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:142)

at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1061)

at org.apache.catalina.core.StandardHost.start(StandardHost.java:840)

at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)

at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:463)

at org.apache.catalina.core.StandardService.start(StandardService.java:525)

at org.apache.catalina.core.StandardServer.start(StandardServer.java:754)

at org.apache.catalina.startup.Catalina.start(Catalina.java:595)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:601)

at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)

at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)

4 answers

I was able to get past this error by switching my JDK version from 1.7 to 1.6. (It was a slightly different problem, but was yeilding the same error message).

I got the same error with a fresh install using jdk 1.7. After switching to JDK 1.6 now it is working.

I am wondering if this has been report to Atlassians's support?

Okay, could you please answer if you solved the problem? Or if the downgrade works?

Thank you in advance.

Nope, haven't solved it yet. I will be downgrading to the previous version...

Have you solved the problem? Because I have the same one.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events