Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,293,795
Community Members
 
Community Events
165
Community Groups

Crowd: 'start_crowd.bat' will not run.

I am installing Crowd.

I refer to 'https://confluence.atlassian.com/crowd/installing-crowd-and-crowdid-191862.html'.

It looks like you installed it properly, but 'Start_crowd.bat' does not run.

Did you incorrectly modify the crowd-init.properties file?(see beloww)

crowd 1.png

3 answers

1 accepted

0 votes
Answer accepted

I want to apologise for being a bit blunt, but the grants are mostly irrelevant. You seem to have got them right.

However, your systems can't connect to the database.  "Cannot connect" is a small step forward as it rules out some stuff, but not a lot.  Check the connections and permissions again, there's something missing.

I've checked again for connections and permissions Installing.(See below)

Crowd and CrowdID:

https://confluence.atlassian.com/crowd/installing-crowd-and-crowdid-191862.html

MySQL:

https://confluence.atlassian.com/crowd/mysql-4030924.html

Running the Setup Wizard:

https://confluence.atlassian.com/crowd/running-the-setup-wizard-192479.html

But I do not know something missing.

Please give me a hint.

Oh, it is my mistake.  I knew the cause.
The crowd database instance name recorded in 'JDBC URL:' is incorrect.(crowd --> crowddb)

crowd 29-1.png

crowd 56.png

 


Thank you very much.

Hi Alex,

You must to create a directory at same structure at your installation of Crow, for example:

Screen Shot 2018-04-30 at 14.18.27.png

After that, you need to change de path at "crowd-init.properties"

<your home diretory>/crowd/crowd-webapp/WEB-INF/classes

Screen Shot 2018-04-30 at 14.23.12.png

Good luck!

I do not know why, but when I re-work today, start_crowd.bat will run.  However, the following error occurs during the installation wizard.

crowd 29.png

The permissions of the 'crowduser' account are fine.(See below)

crowd 30.png

I am waiting for your help.

0 votes

I suspect the batch file does run, but is failing so quickly, you don't see it run.

Could you tell us what happens when you run it on a command line?  (The command line console will retain the output that tells you what the batch file does)

I do not know why, but when I re-work today, start_crowd.bat will run.  However, the following error occurs during the installation wizard.

crowd 29.png

The permissions of the crowduser account are fine.(See below)

crowd 30.png

 

Note that the mysql database name for 'Crowd' is crowddb.

I am waiting for your help.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Service Management

Jira Service Management Documentation Opportunities

Hello everyone, Hope everyone is safe! A few months ago we posted an article sharing all the new articles and documentation that we, the AMER Jira Service Management team created. As mentioned ...

223 views 0 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you