Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Changing SSO Cookie name in crowd does not change the name of the Cookie

Pontus Ridderström August 14, 2018

Hi

I am looking to enable SSO over our internal atlassian products and to deny the possibility mixing up with any other SSO cookie for Atlassian from our customers. We decided to give it an original name.


But we note that when we log in that the default token name "crowd.token_key" is still being utilized.

We have tried to locate where the value is being set in a properties file, we located the documentation "https://confluence.atlassian.com/crowd/the-crowd-properties-file-98665664.html" but with the notice that this file is not used from the crowd version 3.0+ and instead the attribute is stored in the database instead.

My question is where is this "SSO cookie name" attribute stored in the Crowd database for postgresql.
Or if that is the wrong assumption where do i locate where the Crowd "SSO token name" is being stored?

We are running crowd on version 3.2.2 with a connection towards a Postgresql DB version 9.6

Best regards
Pontus Ridderström

1 answer

1 accepted

1 vote
Answer accepted
Bruno Vincent
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
August 14, 2018

Hi @Pontus Ridderström

In Crowd's administration console, go to Settings > General > Single Sign-On cookie settings

SSO_Cookie_Name.png

Pontus Ridderström August 14, 2018

Hi Bruno

Thanks for your answer, i have however already made that change.

When checking towards our Confluence, Jira, Bitbucket the token that is generated when logging in is still named "crowd.token_key"

Best regards

Bruno Vincent
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
August 14, 2018

@Pontus Ridderström

You probably need to restart those three applications to take the changes into account.

If this still does not work, you can override the cookie name in each crowd.properties application file (e.g. atlassian-jira/WEB-INF/classes/crowd.properties) by setting the cookie.tokenkey property:

cookie.tokenkey my.cookie_name

(You will have to restart each application afterwards)

Pontus Ridderström August 14, 2018

Awesome thanks alot.

This solved my original question.

Have a great day :D

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events