confluence v4.1.6

We have installed WIKI production version 4.1.6 in wiki test server and update the license key.   Also, installed MYSQL, create DB username, password and setup the db configuration file as well.

After we setup the user management, we are able to access the wiki URL:  

From the application I tried to restore the WIKI Prod backup to test environment but facing the issue i.e. restoring the backup is taking a long time. I have faced the same issue on earlier as well.

Please find the below snapshot:

wiki.PNG

Please suggest me is there any other possibilities to import the data from Production to Test. 

 

 

 

 

Regards,

Andy.

 

1 answer

This widget could not be displayed.

The alternative to importing is to restore a database backup and a copy of the system's home directory on to the test server.

Actually, we did the same but confluence is not started Nic.

Ok, so which method do you want to run with?

Nic, 

Below are my questions:

/opt/atlassian --> Do I need to copy the entire folder or any specific directories?

Do we need to import the database to test server with same username and password?

Also please suggest me which method do I need to proceed whether XML backup or any other method.

Thanks in Advance!

Regards,

Prasad Eda

 

You need the *home* directory for the server - I can't tell you what that is, but the system information page will.  You don't need to copy the *installation* directory, you should stick with what you've installed on the test server.

Once you've copied the home directory, you should edit the file in the root of the home directory that contains the database connection information.  Because you've copied Live, you'll have live settings in there, you need to change them to point to the test database.

Finally, after you've restored the database into the test one, you should be able to start up the test Confluence.  I'd recommend re-indexing it before starting on any tests.

Hi Nic,

As per your suggestion, i have copied the home directory and edited the file in the root of the home directory. 

To importing is to restore a database backup and a copied of the system's home directory onto the test server.After copied the home directory, edited the file in the root of the home directory that contains the database connection information. Because we have copied Production data, so need to change prod settings in there, So we have changed them to point to the test database.After I restored the database into the test one, start up the test Confluence. à Getting DB issues so I have contacted DB Team and worked on database issue. He fixed the issue after that again I tried to restore but failed to restore.

3)  I have gone through the wiki knowledge base and search the articles I found the solution: 

a) Increased Java Heap Size

b) Increased application timed out seconds. 

c)Restart the wiki applicationAgain I have started to restore the backup from prod to test using zip file including attachments. Restored successfully but unable to login with prod credentials due to some authentication issues.

Please suggest me on

Please suggest me on this.image (2).pngimage (1).pngimage.png

You'll need to read the logs to find out what is going wrong.

2017-06-16 12:40:34,516 ERROR [http-8090-4] [crowd.manager.application.ApplicationServiceGeneric] authenticateUser Directory 'JIRA Server' is not functional during authentication of 'prasad.e'. Skipped. 2017-06-16 12:40:34,519 WARN [http-8090-4] [atlassian.confluence.user.ConfluenceAuthenticator] authenticate OperationFailedException caught while authenticating user <prasad.e>. com.atlassian.crowd.exception.runtime.OperationFailedException         at com.atlassian.crowd.embedded.core.CrowdServiceImpl.convertOperationFailedException(CrowdServiceImpl.java:869)         at com.atlassian.crowd.embedded.core.CrowdServiceImpl.authenticate(CrowdServiceImpl.java:79)         at com.atlassian.crowd.embedded.atlassianuser.EmbeddedCrowdAuthenticator.authenticate(EmbeddedCrowdAuthenticator.java:30)         at bucket.user.DefaultUserAccessor.authenticate(DefaultUserAccessor.java:589)         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)         at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)         at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)         at java.lang.reflect.Method.invoke(Unknown Source)         at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:307)         at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:182)         at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:149)         at com.atlassian.spring.interceptors.SpringProfilingInterceptor.invoke(SpringProfilingInterceptor.java:16)         at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)         at org.springframework.transaction.interceptor.TransactionInterceptor.invoke(TransactionInterceptor.java:106)         at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)

Your Confluence is trying to connect to a JIRA server to get a user directory, but it cannot reach it, or is not authorised to use it.

You'll need to enable it, or make some database tweaks to use a different directory - see https://confluence.atlassian.com/doc/restore-passwords-to-recover-admin-user-rights-158390.html

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

470 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you