Why Are Some Columns Showing No Data In the Page Properties Macro?

We recently upgraded to the new version of Confluence. We have several pages using the page properties macro, all of which are based on the same template. For some reason, two of the columns now display no data at all. There are over 100 documents being displayed on these pages, most of which have data in the affected cells. We have not made any changes to Confluence or to the pages/template specifically.

I went into the macro and made sure that the text actually matched. It did.

One of the affected columns is in the middle of the list, the other is at the end.

What could possibly be causing this to happen?

Any help would be greatly appreciated.

2 answers

1 accepted

0 votes
Accepted answer

So, it turns out that the new version of Confluence treats the 'helpful text' - the grey text that doesn't actually show up unless you're in edit mode - as part of the column heading. The two columns that were displaying blank both had helpful text in the heading cell, and when I removed the text, the columns were populated again.

0 votes
Davin Studer Community Champion Jan 07, 2014

I have one thought that may help. Try rebuilding your index. It is in Confluence admin -> Content Indexing.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,099 views 17 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you