Rich Text Editor Disabled

Hi

I installed the trial version and cannot eddit any page at any level and for any user. I created the pages with an admin user but none admin nor current users can edit the pages. I set up space permissions but still doesn't work. Rich Text Editor looks iike being disabled. I'm using Chrome and Firefox.

Thnx in adnvance

6 answers

There is also a strong link to the user directory you use. As only the internal confluence groups seem to inerit the global permissions.

But check first the global permissions also at <your url>/admin/permissions/globalpermissions.action

Did you check in Confluence Admin -> General Configuration to see if the Rich Text Editing option is selected?

Hi Jo-Anne

thanks for your response too... I've looked at general config like tens of times, but I don't find any specifc option for enabling RTE... In my Configuration > General Configuration there's not any option of that kind... I even searched in plugins, but still the same... I'm a bit lost

Thanks!

Aitor

Answers is not letting me put in an attachment, so I need to do this the long way.

Confluence Administration -> General Settings -> Feature Settings

You don't see the options? I have, for instance:

View Space Goes to Browse Space

Rich Text Editing

Users see Rich Text Editor by default

CamelCase Links

Threaded Comments

TrackBack

.

.

.

If you are not seeing options similar to the following, then what version of Confluence are you using?

Hi Jo-Anne

It's a v4.0 . In Browse > Confluence Admin > Configuration > General Configuration > Feature Settings I've got the following items:

View Space Goes to Browse Space

Threaded Comments

TrackBack

Remote API (XML-RPC & SOAP)

Compress HTTP Responses

Open Search

JavaScript served in header

Did You Mean (English Only)

That's all I have!

Thanks for your response Remon,

I've got an admin user, which belongs to confluence-administrators (every choice selected), and then no specific restriction for the space or pages. I have tried a lot of combinations with other groups and users, restricting and not restricting access, but the editor is always completely disabled. Event the action buttons do nothing when you click them.

Maybe I missed to enable something?

Thanks once again

Aitor

Does anybody know if the Rich Text Editor is based on Tiny MCE Editor Plugin? I cannot enable this plugin for some reason!

Maybe this is why I cannot edit...

I found out that yes, RTE is based on TinyMCE which has not been properly installed during installation... When I try to enable the plugin this is the message in the log:

2011-10-14 18:34:04,282 ERROR [http-8090-15] [atlassian.plugin.manager.PluginEnabler] actualEnable Unable to start the following plugins due to timeout while waiting for plugin to enable: com.atlassian.confluence.tinymceplugin

-- url: /rest/plugins/1.0/com.atlassian.confluence.tinymceplugin-key | userName: admin | referer: http://.../plugins/servlet/upm

Any tip?

Thnx!

Aitor

I was right. The TinyMCE plugin had not been properly installed due to a mismatch in the version of JAVA. I reinstalled jdk1.6, setup the environment variables, restarted confluence and the TinyMCE was properly installed. NOW it WORKS!

Many thanks to Jo-Anne and Remon!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

947 views 13 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you