Problems with SQL plugin timing out.. doesn't appear to be a sql performance issue

We have the following defined in datasource

validationQuery="Select 1"
         removeAbandoned="true"
         removeAbandonedTimeout="600"

However, whenever I look at SQL on the database end, it doesn't even show up. So it's not clear what the delay is.

Is there any way to troubleshoot?

1 answer

Can you open an issue and provide more details. What version of plugin and Confluence? What database? Perhaps logging might help - How to log SQL activity.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,925 views 27 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you