Pasting a numbers from Excel wit the form 0.999 into a table results in cells with the values 1. 999

John Francis January 3, 2020

I have an excel spreadsheet with numbers of the form 0.75464, i.e. Zero Point a string of numbers.

I paste this into a Confluence Cloud Table and the cells with these numbers in are transformed into table cells <td>, containing ordered lists <ol> with the fractional part (or mantissa) only of the number appearing as a list item. This is therefore rendering the number with a proceeding 'Item number' which makes it appear as if it is 1.XXXX, e.g. 1. 75464.

This did not happen on local Confluence Server. I have tried formatting the numbers differently in excel but to no avail. I am using MacOS 10. I have tried with the latest Safari and Chrome.

Screenshot 2020-01-03 at 09.47.40.pngScreenshot 2020-01-03 at 09.48.59.png

1 answer

0 votes
Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
January 6, 2020

Hello John,

Thank you for all the testing you did on this issue!

You've run into a bug that we discovered in Confluence Cloud, which I reported below:

  • CONFCLOUD-68744 Pasting single digit decimal numbers in new editor results in numbered list replacing the first digit

It appears to be related to the formatting, so pasting the contents into a code block or pasting from a raw text document appear to work without auto-formatting to a numbered list.

Please watch that bug so you can be updated when there are any changes or fixes released.

Thank you again.



Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events