Page tree in the sidebar has dissapeared

In our spaces that used to have page tree view in the sidebard to the left, those has dissapeared. I have searched the forum and tried the suggestions with enabling plugins etc, but none of those suggestions match. We use confluence 4.3.2 and I have the Documenation theme on these spaces, and I have the page tree settings ticked under customize settings. There is also childpages connected to the space so this shouldnt be the problem.

Adding the macro page tree works, but this puts the page tree on the pages, not in the sidebar as we want.

I would appreciate any help to solve this issue

4 answers

1 accepted

The problem was solved by enabling the Velocity helper plugin within the Documentation theme

https://confluence.atlassian.com/display/CONFKB/Browser+Title+Shows+$docThemeHelper+Instead+of+The+Page+Title

I wish to thank everyone that tried to help out by offering solutions, and if I somehow missed if someone pointed this out earlier in the thread I appologize alot :)

Cheers to all of you for quickness and commitment to help!

Cheers

B

1 vote
Thomas Schlegel Community Champion Jan 01, 2013

Hi Björn,

did you check the little switch on the left side of the search field on the top of the window ?

Cheers

Thomas

Hi Thomas

I have, if I flip it more ill brake it :) The side bar is there, but its empty, no content at all.

Cheers for the check though

B

Thomas Schlegel Community Champion Jan 01, 2013

ah, ok, you did not mention that the empty side bar is there. Are there any error messages in the log file ?

We have checked the logs, and there is no errors in the log file when I access those spaces

Thomas Schlegel Community Champion Jan 01, 2013

hmm, fighting with the links, sorry ;-)

Do you have a "Home" page in the space

https://confluence.atlassian.com/display/CONFKB/Documentation+Theme+Fails+to+Display+the+Navigation+Bar+in+Some+Spaces

Is this in every space or just in some spaces ? Every Client or some clients ?

Did you change anything before ?

What happens if you deselect the page tree check box and enter the page tree macro in the navigation text box ? (Look at https://confluence.atlassian.com/display/DOC/Configuring+the+Documentation+Theme#ConfiguringtheDocumentationTheme-CustomisingtheDocumentationTheme

Yes, I have a homepage (the link you provided is unknown btw)

It applies to the 2 spaces we have with this, so yes, its for all.

I have tried to add the pagetree to the navigation, by entering this:

{pagetree:root=bjobertest home|searchBox=true}

and also deselected the page tree box, but still no change, I get no page tree.

(bjobertest home is the name of my test space for this (one of the 2 spaces that this concerns))

Any clue? Seems like we have a real issue here, might be needed to file a bug?

Thomas Schlegel Community Champion Jan 01, 2013

Do you have a "Home" page in the space

Look at https://confluence.atlassian.com/display/CONFKB/Documentation+Theme+Fails+to+Display+the+Navigation+Bar+in+Some+Spaces

Is
this in every space or just in some spaces ? Every Client or some clients ?

Did you change anything before ?

What happens if you deselect the page tree check box and enter the page tree macro in the navigation text box ?

Look at https://confluence.atlassian.com/display/DOC/Configuring+the+Documentation+Theme#ConfiguringtheDocumentationTheme-CustomisingtheDocumentationTheme

Thomas Schlegel Community Champion Jan 01, 2013

going nuts... 100 attempts to add a simple link... maybe this time...

Do you have a "Home" page in the space ?

Look at this page

Is this in every space or just in some spaces ? Every Client or some clients ? Did you change anything before ?

What happens if you deselect the page tree check box and enter the page tree macro in the navigation text box as described here

These links work better, but still same result. I will check alysons suggestion and see if that might helps

Hello Bjorn,

From my understanding of it, I believe you need to Rebuild the Ancestor table to get the sidebar showing content again. Not sure if you tried that already, if not can you please give it a try and let us know the results?

Cheers.

Hi Alyson

I have now tried to rebuild the ancestor table with the button, but unfortunately it does not help, I still have empty side bars.

Any other clue?

Hello Björn,

I have read through this answer and a point missing is a Full Reindex From Scratch.

Hope this helps you.

Cheers,

Guilherme

Hi Guilherme

I have tried to rebuild the index, but it does not help either :(

Maybe we can try some of those?

https://confluence.atlassian.com/label/CONFKB/pagetree

Any of them could relate to this :D

Hi, unfortunately none of these worked either. However, my colleague found something that helped https://confluence.atlassian.com/display/CONFKB/Browser+Title+Shows+$docThemeHelper+Instead+of+The+Page+Title it seemed to be the Velocity helper plugin that was disabled in the Documentation theme. When we checked 11/12 were enabled and the Velocity thing was not

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

1,891 views 25 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you