Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,414,249
Community Members
 
Community Events
170
Community Groups

Keyboard shortcuts for Confluence headings don't work in Safari for Mac

Not able to use keyboard shortcuts to format headings in Safari for Mac.

Examples:

  • Cmd+1 should format the text to Heading 1
  • Cmd+2 should format the text as Heading 2

These keyboard combinations don't work in Safari for Mac—although they do work in Chrome for Mac and Firefox for Mac.

(Note: I've checked my system keyboard shortcuts, and these specific shortcuts are not being used for any other applications, which I thought might be causing a conflict.)

FYI: We're running Confluence v4.1 on production (where this is happening). We also run a dev instance of Confluence v5.2.3, where this issue is also presenting.

Anyone else experiencing this problem? Or know what could cause this to happen?

Thanks for any insights, thoughts, good mojo sent this way.

John

5 answers

1 accepted

3 votes
Answer accepted

The command-1,2,3 etc shortcuts in Mavericks Safari map to items in the Bookmarks > Favorites Bar. If your Favorites Bar is empty, the shortcuts will be non-actions. I'm not sure how to unset Safari's use of the shortcuts.

Hi all,

I'm able to change headings in macOS Sierra (10.12.2) using Safari (10.0.2) with the keyboard shortcut cmd+ctrl+# where # is the number of the heading.

YMMV. I'm not sure how I enabled this and the shortcut doesn't work on a different user account of the same machine. Anyone have any ideas?

This should be the accepted answer.

I concur, this should be marked as the accepted answer.

On Confluence Cloud `cmd + option` is now the explicit shortcut listed in the hover over text.Messages Image(1350087893).png

1 vote

Is remaining shortcuts working in your safari browser?

Please check the "General Shortcuts" are enabled or not. Follow this steps: Browser --> 'Browse' menu --> Keyboard Shortcuts --> General --> Enable General Shortcuts mark as required.

hi, Rambabu -

Yep, General Shortcuts are enabled in Confluence.

And other keyboard shortcuts work in Safari/Mac. E.g., bullet (Cmd+Shift+B), numbered list (Cmd+Shift+N), bold, italic, underline.

John

Hi John.

The same problem has been cretaed in atlassian see https://jira.atlassian.com/browse/CONF-24804

Vote for the issue.

Thanks & Regards,

Rambabu

Thanks, Rambabu. I don't think this is the same issue I'm experiencing, though.

I'm using Safari v7 on Mavericks. As far as I can tell, the cmd+1 keyboard shortcut has been deprecated. (I can't find mention of it.)

Hi folks, I found another solution to this problem. You can use markdown like notation to set heading levels.

For example, if you type `##` followed by a space ` `, the hash characters will be removed and your formatting will change to Heading 2. The number of hashes corresponds to the heading level that gets set. Similarly, if you are currently on a heading 2 line, simply try to set it to heading 2 with `##` followed by a space ` ` and it will change to paragraph formatting. 

Thanks, Rambabu. I don't think this is the same issue I'm experiencing, though.

I'm using Safari v7 on Mavericks. As far as I can tell, the cmd+1 keyboard shortcut has been deprecated. (I can't find mention of it.)

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events