Draw.io long loading and stopped to save our diagrams

Hi, it seems that Draw.io stopped to work correctly (after Confluence team made UX changes?).

1. The first issue is, that after clicking on "Insert more content -> Draw.io diagram" (being on already published page), Confluence hangs for about 10 seconds (nothing is being loaded). After that 10 secs - it magically opens Draw.io

2. Second - after creating new diagram and publishing page, we tried to edit it. After clicking on "save" in Draw.io window, thumbnail of diagram changes on Confluence but after clicking "Publish" the updated diagram is not being saved. By that bug, we lost couple of hours of our work today... :-(

We're using Confluence Cloud and tested it on:

  • OS: MacOS Sierra 10.12.3
  • Browser: Google Chrome 60.0.3112.101 (Official Build) (64-bit)

 

1 answer

This widget could not be displayed.

Hi,

I also notice today that we can't update or create new io.draw diagram on Confluence Cloud.

- On Chromium[1]

When creating a new diagram and add a text then save with the filename Hello, and publish, the Confluence page shows `Error: Invalid descriptor`. However, if I download the attachments, Hello.png and hello.xml and open then directly in io.draw, I can see the text.

If I try to edit the newly create diagram from Confluence, io.draw pop up the window to choose a template(e.g. Blank Diagram). If I select a Blank Diagram and add again a text and save, input again the filename. io.draw says `File already exists`.

If now I edit an existing diagram, created few weeks ago, I can see the diagram in io.draw editor. If I edit it and add a text, I can save it. When publishing the Confluence page, the change is not rendered. However, if I edit again the Confluence page, I can see my changes in the macro rendering. However again, if I edit the diagram in io.draw, the change is lost. Likewise creating a new diagram, if I download the attachments and open them directly in io.draw, I can see the text.

- On Firefox[2]

I can create a new diagram and save it. If I update it and publish, the attachments(png and xml) are updated but the Confluence page does not show the changes after publishing. When editing the Confluence page I can see my changes in the macro rendering window.

That's odd! The io.draw plugin was working well like 2 weeks ago (Sep 25, 2017).

- Confluence Cloud version: 1000.0.0-781c963
- io.draw Confluence plugin version:1.4.2-AC

Regards,
Mickael

- [1] Chromium version: 61.0.3163.100 (Official Build) Built on Ubuntu , running on Ubuntu 16.04 (64-bit)
- [2] Firefox version: 56.0 (64-bit) Mozilla Firefox for Ubuntu

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

481 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you