Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Collaborating Editing not working after server migration (no proxy) Edited

Gene Romm I'm New Here Sep 14, 2020

EDIT: I apologize - I seem to have classified it as cloud even though it is server (stand-alone). If a moderator could reclassify, that’d be appreciated. Thanks!


Hello!!

Preface: I am no in way a JIRA/Confluence admin; I just... inherited this and going off the deep end :( 

 

We recently cloned a Windows 2k12 VM that Confluence (v7.3.4) has been running on. The old VM was called hq.old (that is the accessible FQDN) and the new one is called hq.new I've done all the necessary changes (base URL, etc) for both JIRA and Confluence and for the most part, everything works when accessing via hq.new. 

However, I am having difficulty pertaining to Collaborative Editing: 

1. Originally, when trying to create or editing an existing page, I'd get a message stating 

Loading the editor's taking longer than usual. Give it a few moments, then refresh your page if it still doesn't load. Speak to your Confluence admin if that doesn't fix it.

Digging a bit further, I discovered that despite changing the base URL in Confluence and despite restarting synchrony, it appears that heartbeat check was still using the old URL: 

http://hq.old/synchrony/heartbeat?_=XXXXXXXXXXX

I've tried resaving base URL and restarting Synchrony, but not dice. So, in checking the database, I discovered that synchrony_collaborative_editor_app_base_url bandanakey in confluence.bandana was still pointing to hq.old. I manually changed it to use hq.new - so this is what it looks like now: 

<string>http://hq.new:8090/synchrony-proxy,http://hq.new:8090/confluence/synchrony-proxy</string> 

2. After doing the above, then restarting confluence (and synchrony for a good measure), I now able to open the edit (create a new page or edit existing), however I get a message now indicating 

Something went wrong after loading the editor. Copy your unsaved changes and refresh the page to keep editing.

In checking the traffic path when opening the editor - I am seeing these calls being blocked: 

http://hq.new.echromics.corp:8090/synchrony-proxy/v1/data/Company-b83ab47d-a18b-3c2e-967c-885976e09424/confluence-69599475?state-at=@head&state-format=type-tagged&rewrite-request=true&cached=true

The response from the server comes up as this:

{"type":"jwt/invalid-aud","message":"Error validating JWT:JWT aud property does not match expected value"}

 

At this point I am stuck... any suggestions? According to ..\Atlassian\Confluence\conf\server.xml - I am running no proxy: 

 

<Server port="8000" shutdown="SHUTDOWN" debug="0">
<Service name="Tomcat-Standalone">
<!--
==============================================================================================================
DEFAULT - Direct connector with no proxy, for unproxied HTTP access to Confluence.

If using a http/https proxy, comment out this connector.
==============================================================================================================
-->
<Connector port="8090" connectionTimeout="20000" redirectPort="8443"
maxThreads="48" minSpareThreads="10"
enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8"
protocol="org.apache.coyote.http11.Http11NioProtocol"/>

 

1 answer

1 accepted

0 votes
Answer accepted
Brant Schroeder Community Leader Sep 14, 2020

Gene I would suggest changing the URL back in the DB and following the steps closely.  https://confluence.atlassian.com/confkb/unable-to-edit-any-pages-in-confluence-due-to-collaborative-editing-867362716.html 

Also what are you seeing in the logs?  

Brant Schroeder Community Leader Sep 14, 2020

One additional question what happens if you turn off collaborative editing?  Does everything work?

Gene Romm I'm New Here Sep 15, 2020

Hi @Brant Schroeder

Funny enough - I followed the instructions you've posted, to the T, before I posted my issue. None of it worked... the only progress I had was after changing the database. 

Today, per your suggestion, I reverted changes to the database and put in hq.old instead of hq.new, wrote the changes, then restarted synchrony. 

Then, I tried something different: went to General Configuration (which did show proper server base URL), clicked on edit, then clicked on save without actually doing any changes, went back to collaborative editing and restarted synchrony... and like magic, it started working. Checked database too - and it changed the URLs back to hq.new (by itself this time). 

I must've done iterations of this a zillion times yesterday... but maybe it's just the specific sequence that got it right. 

 

Thanks for the nudge in the right direction - I probably would have gotten there sooner or later; just glad it was sooner than later :) 

Brant Schroeder Community Leader Sep 15, 2020

Glad to hear your issue has been resolved.  Can you accept the answer to help others.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

113 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you