Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't view site on Mobile browser - Redirects to many times

I just upgraded my confluence and bought a new license to help debug this issue. Not only did it not fix the issue but now I find that Atlassian won't offer to help with starter licenses. I feel like putting a big warning on my webpage.....

 

For about a YEAR now I can't view my site on Android Chrome, but when I hit 'View Desktop Site" it works as expected. I mostly view my site on a desktop since it's for technical documents, but it bothers me and I'm finally looking into it.

 

https://unix.stackexchange.com/questions/492146/confluence-site-viewing-via-android-chrome-redirects-url-to-many-times-but-deskt 

 

It seems to always redirect too https://www.freesoftwareservers.com/#content/view/327684

1 answer

0 votes
Daniel Eads Atlassian Team Mar 14, 2019

Hey there,

Sorry for the confusion on licensing, we actually DO offer help with starter licenses - just here through Community! This is outlined on the Starter license FAQ.

I've taken a look at your nginx configuration and don't see anything apparently wrong. Confluence serves on port 8090 by default and you've set your proxy to 8091, but since it's working on Desktop for you, I have to assume you've set Confluence to serve on 8091. And while nothing struck me as non-functional in your nginx config, I do maintain one for reference that you can compare against here.

In addition to your nginx config file setting a particular URL that nginx will listen for, you need to make sure Confluence's application server and Confluence itself both expect that same address, and expect it to be HTTPS:

  1. The server.xml file in <confluence-install>/conf needs to have the following options added at the end of your active connector (fill in proxyName with the URL you're serving):
    scheme="https"
    proxyName="yourdomain.com"
    proxyPort="443"/>

    Here's a full connector serving on port 8090 for reference:
    <Connector port="8090"
           maxThreads="200"
           minSpareThreads="25"
           connectionTimeout="20000"
           enableLookups="false"
           maxHttpHeaderSize="8192"
           protocol="HTTP/1.1"
           useBodyEncodingForURI="true"
           redirectPort="8443"
           acceptCount="100"
           disableUploadTimeout="true"
           scheme="https"
           proxyName="yourdomain.com"
           proxyPort="443"/>

    Note that if you needed to make changes in server.xml, you must restart Confluence before they'll take effect. Don't forget to restart!
  2. The Base URL in Confluence needs to be the same as what's in the proxyName field, but also have https:// in front. So if your proxyName is domain.com, your Base URL should be https://domain.com - see these steps for updating the Base URL  if you're unsure where to set this within Confluence.

My guess is that one of these two is not the correct value right now, and fixing those should get you back in business.

We also offer an Android app for Confluence Server that you should check out! You need to be running Confluence 6.8 or above for the app to connect to your server. The app offers easier navigation and push notifications - definitely my preferred method for browsing Confluence while on the go.

Cheers,
Daniel | Atlassian Support

Yeah I though I remembered getting support years ago, sorry it's confusing when you try to open a ticket it says "we don't support the start lic" but thats for a different ticket system. While this may be a "community" page, I have often gotten stellar support from what appear to be Atlassian Emp!

 

I'm happy to say my site is mobile friendly again, and that I'm on the latest version. But, I was recently spam attacked and am unable to delete all comments. I would love this feature to be implemented. I have tried to add-on's but they only let you delete per page I need to delete per space! I have enable captcha's but for now i've just disabled comments and deleted the majority. That's all another post though, thank you so much! I'll try to update the SE post as well, but they say it's not related to Unix....

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

Welcome to the Confluence Holiday Workshop 🎁

Welcome to Confluence’s Holiday Workshop, where knowledge and collaboration collide! This year come celebrate the holidays with brand-new Confluence features to kickoff your new year, best practice...

421 views 11 31
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you