Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,367,387
Community Members
 
Community Events
168
Community Groups

after new installation, confluence very slow

Good Day Community

After windows update i got a issue, "confluence login Can't connect to your H2 database"
As the server was older i decided to copy the backup away and install a new 2019 server and install confluence new, restore.... All OK, just....
After reboot its taking ± 10 minutes till confluence is running, when its running login into it from a workstation is also taking some minutes.....
Any help / tips are welcome :-)

Thank you very much and have a great day!!!!!

3 comments

Rilwan Ahmed Community Leader Sep 20, 2022

Hi @Hans Hoogstrate ,

The embedded H2 database is only supported while you are evaluating Confluence. You must migrate to a supported external database before using Confluence as a production system. 

You can check the supported platforms here: https://confluence.atlassian.com/doc/supported-platforms-207488198.html 

Please go through Server Hardware Requirements Guidesystem Requirements.

Configure your confluence as per the standard and re-check how it is working. 

You can also refer performance tuning document for more info: https://confluence.atlassian.com/doc/performance-tuning-130289.html

Hello Ahmed, Thank you for your reply,

H2 is NOT on the new server. Its a fresh installation windows server 2019) and Fresh installation confluence, (so the standard db software which confluence is using will be installed)

 

Hi @Hans Hoogstrate 

Sounds like you are running into some performance issues. Can you please help with the below questions?

  • Are you using Confluence with some external database or you are running it with the evaluation database, H2 that comes with the installation files?
  • Is Confluence slow only while coming up after the reboot or slow in general?

Typically for performance issues, we would require the thread dumps captured while the performance is slow. Next time you face this issue, please collect the thread dumps using the steps listed below docs

Attach the thread dumps and we will check them for you.

Thanks,

Aamir

Good Day Aamir, Thank you for your reply, i guess it installed the evaluation database (i done a standard installation), no seperate database.
i will attache the requested file, thank you for your help!

hmm..... where can i drop the zip file......

You can try to attach the Zip here. In case it's not allowed to drop the zip due to security reasons, I'd suggest opening a case with Atlassian Support. 

Basically, they would require thread dumps to analyse this issue.

Thanks,

Aamir

unfor. not going to drag and drop. :-(

if you want drop me a email, i will send the zip file (only 11mb)
hans@connecta.net

Comment

Log in or Sign up to comment
TAGS

Atlassian Community Events