Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


setting git config is not reflecting on bitbucket server


We are using bitbucket server's auto merge feature.

But in few of our repos, we don't want this to happen for a specific file.

We expect, if the conflict occurs for this file during merge, destination branch version should get used.
Therefore, we have added the a line in .gitattributes file.

<file-name> merge=ours

Additionally as per git documentation, we have to use custom merge driver,
so we ran following command on bitbucket server

git config --global merge.ours.driver true
git config --system merge.ours.driver true

As per this article, since we are unsure about the user with bitbucket server was started
so, we had set the config at global as well as system level.

But for some reason the value is NOT getting reflected. and we are getting conflict error which we do not expect.

Can anyone suggest anything we are missing here?

0 answers

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events